Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried sudo mount -t /media/66CC2BC0CC2B88FF/ubuntu/disks/disk.root -o ro,loop=/dev/loop0 but it didn't work. Any suggestions? TY!

share|improve this question
2  
Please elaborate on what you are trying to accomplish and why. The command and its arguments you typed doesn't make any sense, so it is not strange it doesn't work. –  jippie May 4 '12 at 7:15
    
i try to mount a file disk.root(my previous wubi) to be able to browse it directly from my new clean installation(not wubi) –  Martin May 4 '12 at 7:17
    
The -t option specifies the filesystem type, but you haven't supplied any. This is not usually required, but if you use -t you have to specify ext3 or ext4 or auto. From the man page: "If no -t option is given, or if the auto type is specified, mount will try to guess the desired type." If mount cannot detect the filesystem type then it's probably corrupted and you'll need to fsck it. You don't need to specify the loop device either, although you can. Jase's answer is all you need. –  bcbc May 4 '12 at 20:17
add comment

1 Answer

You should be able to use the following command to mount your virtual disk:

mount -o loop /media/66CC2BC0CC2B88FF/ubuntu/disks/disk.root /mnt

After running that, the files from your wubi installation should be available in /mnt

share|improve this answer
1  
10x it worked perfectly! –  Martin May 9 '12 at 7:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.