Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having problems with image quality when reducing images or zooming out in certain applications. It looks almost as if the image is not being smoothed or anti-aliased.

http://i.imgur.com/T6oPu.png

On the left is gthumb/eog (look the same) - on the right is gimp. Left one is clearly broken. It never used to be like that. Those are at 20% zoom: they're identical full size. [EDIT: Actually they don't but the difference is minor; left is still worse.]

Eye of Gnome (EoG) and GThumb both suffer from it when resizing to reduce, and when zooming out to reduce, but oddly Gthumb doesn't suffer when generating thumbnails. Shotwell and Gimp are unaffected. Libre Office is affected.

Given this, I wonder if anyone might know which component(s?)/issues are the cause? I'm on a 64 bit precise with NVidia 8800 GTX (nouveau).

EDIT: Additional information. If i use the tools dropdown button in the top toolbar of Gthumb, it reduces images size and retains full quality. If I instead click the paint palette at the top right to enter Edit Mode, and resize from in there, it loses quality. The "high quality" check box makes a difference but not significantly. The zoom also loses quality. I am wondering if perhaps it doesn't have 2 rendering modes and 1 is broken?

EDIT 05May2012: I have since discovered that

(a) The image quality for EoG and Gthumb suffered its regression in Oneiric (Maverick, Natty work fine).

(b) It is not limited to Ubuntu, it also affected Fedora 16.

So I'll take as an accepted answer anyone who can either fix that or advise me how to go bug reporting this. I don't really know which packages to apply it to, or whether it needs to go to Ubuntu or Gnome. Thanks!

share|improve this question
add comment

4 Answers 4

up vote 6 down vote accepted

This is bug 665897 in Gnome.

https://bugzilla.gnome.org/show_bug.cgi?id=665897

share|improve this answer
add comment

I faced the same problem and I looked for an alternative. I installed an app called Mirage from the repos and set it as the default image viewer. Mirage offers two big advantadges over the default image viewer:

  1. Image scaling is properly done.
  2. It preloads the next image so viewing a set of images is much more pleasant without having to way on sec. every time you click "next image".

IMHO the way the default image viewer scales the images is a bug (and should be corrected in following updates). The second is a feature (a trick if you want) that should be implemented in the default image viewer because it's one of those things that make people say "this is way faster in Windows".

share|improve this answer
1  
This is really helpful, however, while I can live without EoG, Gthumb is more of a problem since it's also an image management package and I use it for simple photo processing. Gthumb does however have the option to send to gimp (click photo and press g). –  gecko May 5 '12 at 14:44
1  
Just re-commenting to again say thanks, and that I've updated the question. –  gecko May 5 '12 at 14:53
add comment

Open gThumb and go to "Edit" > "Preferences" and make sure that "Smooth images" are checked.

enter image description here

share|improve this answer
3  
Have tried already, does not really make a difference. Have additional screenshot if you want to see, that shows the checkbox and the images together. However I have tried a Fedora liveCD and it too has the problem, so it's something in Gnome that has changed since the previous gnome I had. I will a maverick etc liveCD later to see which release had the regression. –  gecko May 5 '12 at 2:08
    
I am sorry it is not the fix. –  desgua May 5 '12 at 2:25
    
No need to apologise, you have done nothing wrong! I have updated the question, however. –  gecko May 5 '12 at 14:53
add comment

Ok, I had the same problem... Spent a long time trying to fix it. With gthumb doesn't seem to be a problem with system settings or a bug etc but rather that the Ubuntu official repositories do not carry an up to date version of gthumb. The latest versions have much better anti-aliasing. I tried lots of methods of getting a newer version of gthumb including downloading .deb files, building from source, using the PPAs on the gthumb website but none of them worked for me. For any novices like me here's what did.

First uninstall the old gthumb - from the terminal (Ctrl+Alt+T) run

sudo apt-get remove gthumb

Then I added the following repositories to the top of my /etc/apt/sources.list. They have to be on top because when you 'apt-get install gthumb' it will download from the first repository listed which contains a package called gthumb. If you put it beneath the official Ubuntu repositories you will just get old gthumb again.

So you have to run a text editor as root from the terminal to edit the file for example

gksudo gedit /etc/apt/sources.list

or because I'm running Xubuntu I did

gksudo mousepad /etc/apt/sources.list

Then add the following two lines to the top, save and close:

deb http://ppa.launchpad.net/dhor/myway/ubuntu saucy main 
deb-src http://ppa.launchpad.net/dhor/myway/ubuntu saucy main 

Then run

gpg --keyserver keyserver.ubuntu.com --recv-keys E2B7D64D93330B78 && gpg --export --armor | sudo apt-key add - && sudo apt-get update

in the terminal to get the key for the PPA.

Then you can run

sudo apt-get install gthumb

and it should install gthumb 3.2.4 with great anti-aliasing

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.