Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Wired PS/2 keyboard and mouse do not work in 12.04, either in a fresh install or from the Live CD. A USB keyboard and mouse will work. The PS/2 keyboard and mouse will work using the same hardware and a fresh 10.04 Ubuntu install or a fresh Windows 7 install. The motherboard is a Foxconn D270S Atom based motherboard. This problem is specific to this motherboard and Ubuntu 12.04.

So far I've tried running in the fresh 12.04 install:

sudo apt-get install
sudo apt-get upgrade
sudo apt-get dist-upgrade

After the apt-get upgraded the first time, I now get to the point where there are 0 items to be upgraded. Rebooted and still no PS/2 keyboard/mouse.

I've also tried adding the following lines to GRUB at boot time (the PS/2 keyboard works in GRUB)

acpi=noirq
acpi=off

Neither setting made any difference.

The motherboard is a Foxconn D270S Atom based motherboard. Even more interestingly, 12.04 recognizes the same PS/2 keyboard and mouse on a separate Gigabyte AM3+ based motherboard. I only have this problem on this particular motherboard with Ubuntu 12.04.

Any help would be appreciated. I bought this low-power motherboard specifically for the task of running Ubuntu 12.04 for the next five years...

Update...

I dug out an old PS/2 mouse that does not use a PS/2 to USB adapter but is directly wired for PS/2. Still no PS/2 keyboard or mouse after reboot. Again, I only have this problem with this motherboard and 12.04 Ubuntu. Other motherboards work fine with 12.04 and this motherboard works fine with 10.04.

Update 2...

I installed the 12.04 Server version. The text-based installer recognized the keyboard without issue, but after the first boot into the installed OS, the PS/2 keyboard would no longer respond. I tried installing Gnome on the Server install and the PS/2 mouse and keyboard don't work in Gnome either.

I Opened bug #995570 for this issue

share|improve this question
    
I'm using a computer (not a laptop so don't have keyboard at all), with USB keyboard, even I'm having similar issue. After reading this question I've not tried solutions at grub, however found bugs.launchpad.net/ubuntu/+source/linux/+bug/990870 –  wisemonkey May 5 '12 at 18:10
    
Since this appears to be the result of a bug, this question is off-topic for this site. Good luck getting it resolved :) –  Chris Wilson Mar 24 '13 at 11:41
add comment

closed as off topic by Seth, Kevin Bowen, hhlp, Chris Wilson, Thomas W. Mar 24 '13 at 15:51

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

They might be disabled at the BIOS, or if your are connecting them through a PS2 to USB adapter, that particular USB adapter might not be recognized by ubuntu.

share|improve this answer
    
Hmmm...Why would the PS/2 mouse and keyboard work with Ubuntu 10.04 then? What's different in 12.04? Yes, the mouse uses the PS/2 to USB adapter that it came with, but the keyboard does not. –  david krajewski May 4 '12 at 3:29
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.