Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an acer aspire 722, I recently went to use gmail/talk as well as empathy and realized that the microphone does not work. I checked the sound settings, adjusted microphone level, did a mic test but the level indicator showed no bars.

share|improve this question
    
Which version of Ubuntu are we talking about here? –  Benjamin Aug 27 '12 at 5:21
add comment

3 Answers

Now my speakers work & mic work:

  • I installed linux-image-3.4.0-999-generic-pae_3.4.0-999.201205070447_i386.deb
  • and then adjusted mic boost in alsamixer
  • sudo alsactl store
  • added to startup applications: alsactl restore
share|improve this answer
1  
linux-image-3.4*? All that's available to me is up to 3.2 in Precise. –  Benjamin Aug 27 '12 at 5:30
add comment

You need to unmute the microphone input. Try running alsamixer in a Terminal window (Ctrl+Alt+T), and checking it there. If it's muted or low, you can unmute and/or increase it in alsamixer.

share|improve this answer
add comment
  • Open a terminal window by pressing Ctrl+Alt+T and type: alsamixer.
  • Press F6 and choose 1 HDA ATI SB as a sound card to configure by pressing Enter.
  • To see the mic-related sliders, press F5 and move the cursor keys to the right, only the outermost three sliders need to be set to a level of 56 by pressing the Up key
  • Then, by pressing the C key on each of the three sliders, the volume level of each right channel needs to be put to 0
  • finally, quit alsamixer by pressing ESC.

See: https://help.ubuntu.com/community/AspireOne522#Microphone

After each reboot, you may need to toggle the Mute button by:

  • Click on the speaker icon on top right panel and choose Sound Settings...
  • Click on the Input tab (second from left) and adjust input volume to Unamplified 100% and say something to see if the input level indicator moves enough. If not, click on Mute to mute and then click again to unmute.

Hope this helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.