Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgrade ubuntu to v12 and flightgear quit working. So I uninstalled it and tried the reinstall it but it will not install. This is what happens when I try to install it. "Package dependencies cannot be resolved This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time. Details

The following packages have unmet dependencies:

flightgear: Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
            Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed

" I am on 64bit system

Any help would be greatly appreciated. Thank you for your time

share|improve this question

2 Answers 2

I fixed it! here is what I did.

I had to make a dir /usr/share/games/flightgear so apt-get could remove it. Then I sudo apt-get remove fgfs-base

I then installed flightgear via Ubuntu Software Center

share|improve this answer

Do you have any extra PPA's active? Are you trying to install FlightGear from a .deb file? I was able to do a simulated install of FlightGear on my 12.04 desktop without issue just using

apt-get install flightgear
share|improve this answer
    
I'm not sure about the PPA's. I tryed to install from software center that is when I got to above error. I tied to sudo apt-get install flightgear and got the folowing error. " The following packages have unmet dependencies: flightgear : Depends: fgfs-base (>= 2.4.0) but it is not going to be installed E: Unable to correct problems, you have held broken packages. –  Bobby Levesque May 5 '12 at 11:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.