Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a problem with my DHCP but I managed to fix it. Now the network starts but I have a problem with DNS. Clients in the network don't get any dns from my DHCP.

My network works as follow my I connect to wireless device then I share it throw out my Ethernet cable.

My configuration:

/etc/dhcp/dhcpd.conf

 #/etc/dhcp3/dhcpd.conf option subnet-mask 255.255.255.0; default-lease-time 600;     
 max-lease-time 7200;  subnet 192.168.27.0 netmask 255.255.255.0 {   
range 192.168.27.10 192.168.27.20;   
option broadcast-address 192.168.27.255;   option routers 192.168.27.1; }

in /etc/default/dhcp-server I added

 INTERFACES="eth0" 

in /etc/network/interfaces

iface wlan0 inet dhcp wireless-essid default  iface eth0 inet static address  
192.168.27.1 netmask 255.255.255.0 gateway 
 192.168.0.100 pre-up /sbin/iptables-restore /etc/network/iptables

in /etc/resolv.conf

I have two nameservers for dns

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 212.72.23.30
nameserver 62.231.243.249

but my clients in the network don't get them and even if I give them static ones no INTERNET does work.

I followed this the tutorial on this website: https://help.ubuntu.com/community/EasyWirelessToWiredConnectionSharing
there were some changes I had to change to make it work, I followed so other guide from other websites to make it run. so now network dhcp is working but no dns is working on the clients side.

any help will be appreciated.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You need to add these lines to your configuration file.

#your search domain option
option domain-name "mydomain.biz";
#your dns server
option domain-name-servers 192.168.1.1;
share|improve this answer
    
thanx that helped fix it thanks alot –  flox12 May 14 '12 at 12:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.