Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have Ubuntu 12.04 and ooo-thumbnailer does not work. I have installed it from the above ppa and restarted nautilus, of course, but no thumbnails whatsoever are created.

When I call ooo-thumbnailer from the command line I gen the following:

convert convert: Improper image header (/tmp/gmJ6Jks5).

It is something it has to do with the imagemagick convert utility. I have installed the graphics-imagemagick-compat package, but I also tried to substitute that with the imagemagick package. In this case ooo-thumbnailer still doesn't work but the error code is different (I don't recall precisely now).

I also tried to compile ooo-thumbnailer and imagemagick from source with no success.

Anyone knows what the problem might be? Thanks


share|improve this question

1 Answer 1

I've just discovered that this is due to a minor bug in the "ooo-thumbnailer" package. Until a new version is released, I've managed to get thumbnails displayed again in this way:

1) As root, create a new (plain text) file, which is missing:


2) Open this new file with your text editor (e.g. gedit or medit) and paste the following text:

[Thumbnailer Entry]

Exec=/usr/bin/ooo-thumbnailer %i %o %s

3) Save this file and restart Nautilus using this command in user terminal:

nautilus -q

You should now have thumbnails generated and displayed for all supported file types like ODT and so on...

share|improve this answer
It is a shame that this hasn't been fixed in 14.04... – Ed Villegas May 4 '14 at 2:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.