Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't install VMwarePlayer 4.0.3 on Ubuntu 12.04 64Bit. For Version 4.0.2, I found a script that I have to run and after that I could install 4.0.2. Is there an similar solution for Version 4.0.3?

share|improve this question
    
on VMware Kernel Module Updater -Dialog I get the Error on Compiling "Virtual Network Device" and an Error-Messagebox: "Unable to start services." –  Marian Lux May 3 '12 at 18:30
add comment

7 Answers 7

up vote 42 down vote accepted

I ran into the same problem, and I was able to make the same patch work by editing a version number in the script which applies it.

WARNING: I don't actually know what I'm talking about when it comes to VMware patching, I just made an educated guess that seems to work.

Whether you want to try this yourself depends on how risk-averse you are. But hey, your VMware Player install is already broken, right? I figured worst-case scenario I could uninstall and reinstall version 4.0.2.

I based this on the instructions I found here: vmware player compile issue. To boil it down to the simplest steps:

  1. Download this tarball: http://weltall.heliohost.org/wordpress/wp-content/uploads/2012/01/vmware802fixlinux320.tar.gz
  2. Extract the tarball in your home directory
  3. Edit the file patch-modules_3.2.0.sh. Look for the line plreqver=4.0.2 and change it to plreqver=4.0.3
  4. Save the file, then run it. sudo ./patch-modules_3.2.0.sh

If you have run the same patch on version 4.0.2 before, you may get this error: "/usr/lib/vmware/modules/source/.patched found. You have already patched your sources. Exiting". If you see that, just delete the /usr/lib/vmware/modules/source/.patched file and try again.


Please remember to have patch packet installed: apt-get install patch. My default installation of latest Kubuntu didn't have it, so I got error:

./patch-modules_3.2.0.sh: line 42: patch: command not found

Sometimes, the version check does not properly. In this case, you could remove it by deleting the 4 lines following "unset product", all of them begin with "[". This again may increse the risk of breaking something.

share|improve this answer
    
Thank you very much! It works! –  Marian Lux May 4 '12 at 6:31
1  
+1 for the hack to change 4.0.2 to 4.0.3 !! –  Yugal Jindle May 19 '12 at 6:13
    
+1 Awesome, It worked after changing 4.0.2 to 4.0.3 –  Caterpillar Jun 3 '12 at 4:37
4  
This workaround also works for Vmware Player 4.0.4 (change 4.0.2 or 4.0.3 in the patch-modules_3.2.0.sh-File to "4.0.4"; check if "patch"-package is installed on your system or get it from the Ubuntu Software Center; remove the ".patched" file if you get an error during patching - if you have already patched for an other version - type: /usr/lib/vmware/modules/source/.patched in terminal) –  Marian Lux Jun 15 '12 at 9:53
    
@dbrewer, I got this from a submitted edit but I can't tell if it's correct, can you look at it and see if it's necessary to add to your answer? "Helllo, your answer is very strong and congratulate!!!! But i have to mention that after editing the patch-modules_3.2.0.sh file we need to change not only the plreqver=4.0.3 but also the vmreqver=8.0.4 and follow the steps that you described. AND it'll work." –  Jorge Castro Jul 25 '12 at 20:50
show 2 more comments

Since VMware Player is not provided by the repositories, you have to instead download it here at the VMware website.

To install VMware Player, download the latest version for your architecture (newer versions are at the top of that list. That is, if you're running the 32-bit version of Ubuntu, get the 32-bit version, and if you're running the 64-bit version of Ubuntu, get the 64-bit version. If you're not sure which version of Ubuntu you're running, press Ctrl+Alt+T to open a Terminal window, then type in uname -m and press enter. If it says x86_64, you're running the 64-bit version of Ubuntu. If it says i686, you're running the 32-bit version of Ubuntu.

After the download completes, go to the folder to which you downloaded it in the Terminal. You can do this with the cd command. For example, if you put it in your Downloads folder, run:

cd ~/Downloads

(In the Terminal, the ~ character at the beginning of a file path represents your home folder.)

Now make this installer file executable with the chmod command. Currently, VMware Player 4.0.3 Build 703057 is the latest version, so for the 32-bit installer you'd run:

chmod +x VMware-Player-4.0.3-703057.i386.txt

Or for the 64-bit installer you'd run:

chmod +x VMware-Player-4.0.3-703057.x86_64.txt

(For future versions, the naming convention might change. In particular, the installers are usually named .bundle rather than .txt, since they are not true text files. Just use the full name of whatever file you download.)

The installer may need to build and install kernel modules, so it's advisable to make sure you have the necessary packages to facilitate this. Run uname -r. The output should end in generic, generic-pae, server, or virtual. If it doesn't end in generic, replace generic below with whatever it does end in.

sudo apt-get update
sudo apt-get install build-essential linux-headers-generic

Now run the installer. You have to run it as root, so use sudo:

sudo ./VMware-Player-4.0.3-703057.i386.txt

Or for the 64-bit version:

sudo ./VMware-Player-4.0.3-703057.x86_64.txt

The rest of the installation process is guided and graphical. While you had to run the installer as root, you do not generally need to (and should not generally) run VMware Player as root after you've installed it. Occasionally, after an update to your kernel or VMware Player, VMware Player may ask you to allow it to build and install new kernel modules as root. That's OK.

Note: You may get a kernel error when running it for the first time, if so try:

cd /tmp
wget http://communities.vmware.com/servlet/JiveServlet/download/1553530-39784/patch-modules.sh
wget http://communities.vmware.com/servlet/JiveServlet/download/1553530-39785/vmware-7.1-2.6.35-3-generic.patch
sudo sh patch-modules.sh

If that doesn't work (and it asks you for the patch location) try this for the location:

/tmp/patch-modules.sh

This extra information was taken from here, and all I did was add the /tmp/patch-modules.sh. If it doesn't work try referring to the forum link above.

share|improve this answer
    
Thanks, I can install the VMWare, but after I run some modules updater under kernel, it prompted me an error "unable to start services, see logfile.... –  willy May 15 '12 at 21:42
    
I got patch module update 3.2.0.sh , I can run my VMPlayer now, thanks :) –  willy May 15 '12 at 22:03
    
Can you share the link to the patch ? –  Yugal Jindle May 18 '12 at 9:52
    
@willy Can you tell us how you got the patch? I'd like to add that to my answer. –  Eliah Kagan May 18 '12 at 15:16
1  
It's no longer required you to register/login to get the installation file from their download page –  Adonis K. Aug 28 '12 at 18:48
show 3 more comments

http://downloads.vmware.com/d/info/desktop_end_user_computing/vmware_player/4_0

Click on download Then Register IT enter image description here Complete Registration enter image description here Then Download The Version You Want To I Have Ubuntu 11.10 x64 bit enter image description here Download enter image description here Once Downloaded then run the Following Command

  sudo apt-get install build-essential linux-headers-`uname -r`

then go to your Download Directory

cd Download   (full command will be cd /home/your-user-name/Download)
ls -l
gksudo bash ./VMware-Player-4.0.2-591240.x86_64.bundle

enter image description here enter image description here enter image description here enter image description here

enter image description here

Help Taken

http://www.howtoforge.com/how-to-install-vmware-player-on-ubuntu-11.04-linux-mint-11

https://help.ubuntu.com/community/VMware/Player

share|improve this answer
    
pic no 5 6 7 8 will show you version 4 , as i have copy pasted , so dont worry abt it –  One Zero Feb 3 '12 at 18:38
    
+1 for an intuitive explanation. –  i08in Mar 28 at 19:19
add comment

You can download the Vmware player for Linux from the official website with .bundle as the extension.

After that navigate to the downloaded folder in terminal.

Then use the command:

sudo sh filename.bundle 

it will do the remaining job.

It worked for me.

share|improve this answer
    
VMWare Player 5.0.1 is the current version and it worked just fine for me. I used the instructions from here: liberiangeek.net/2012/09/… –  draganstankovic Nov 10 '12 at 14:50
add comment

Works for different Versions, i tested it with version 4.0.4.744019:

Run vmware-installer -l in a console to get version number.

Edit the file patch-modules_3.2.0.sh:

  1. Look for the line plreqver=4.0.2 and change it to plreqver=[copy and paste version number, just the three digit x.x.x ]

  2. Remove the following lines:

    unset product [ -z "$vmver" ] && error "VMWare is not installed (properly) on this PC" [ "$vmver" == "workstation$vmreqver" ] && product="VMWare WorkStation" [ "$vmver" == "player$plreqver" ] && product="VMWare Player" [ -z "$product" ] && error "Sorry, this script is only for VMWare WorkStation $vmreqver or VMWare Player $plreqver"

    [ "id -u" != "0" ] && error "You must be root to run this script" [ -f "$ptoken" ] && error "$ptoken found. You have already patched your sources" [ ! -d "$basedir" ] && error "Source '$basedir' directory not found, reinstall $product" [ ! -f "$fpatch" ] && error "'$fpatch' not found. Please, copy it to the current '$curdir' directory"

Now run the patch via sudo sh patch-modules_3.2.0.sh

share|improve this answer
add comment

Virtualbox is similar to VMware player, but in contrast to VMware player it is contained in the repositories. The advantage for pulling from repositories is that you don't have to worry about updates, they come with the regular system updates. Virtualbox can read VMware images.

From the command line apt-get install virtualbox, or search for virtualbox in the Software Center.

If you really want to install VMware Player, find the .debinstallation file for your architecture (32 or 64 bit). Usually double clicking will start installation. You are required to take care of all updates yourself in this case.

share|improve this answer
add comment

VMWare Player is not available for Linux. However, there is an alternative for that: VirtualBox. You can download VirtualBox for Ubuntu from their website. If you want the latest version or for an old version just type and search it from the Software Center and install it. It is easy to install from the Software Center. If you have downloaded the package from the VB site, then right click on the .deb file and select open with Software Center.

share|improve this answer
1  
VMware Player is currently and has always (since it first came out) been available for Linux. –  Eliah Kagan May 12 '12 at 20:28
    
Thanks, I can install the VMWare, but after I run some modules updater under kernel, it prompted me an error "unable to start services, see logfile..... –  willy May 15 '12 at 21:40
1  
@willy Without the log file, it would be hard for us to advise you. If you can find the log file, I recommend accepting an answer to this question and posting a new question. (You could post a link to the new question as a comment to this question.) If you can't find the log file, then what is the full and exact text of the error message? –  Eliah Kagan May 16 '12 at 3:35
add comment

protected by Community May 4 '12 at 15:39

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.