Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed xubuntu-desktop on a 12.04 Ubuntu upgrade after finding Gnome3 lacking. I've mostly been happy, but I've found an odd and frustrating bug. My laptop has two sound 'outputs' - an HDMI-out plug I never use, and the onboard speakers/headphones. For some reason, the hardware keys have been mapped to the HDMI output, even if I set it as 'fallback' in pavucontrol, and notify-osd only displays changes in the HDMI output (though the panel indicator volume control controls onboard sound). I'd ideally like both hardware keys and notify-osd to be looking at the onboard sound, though if I can't get notify-osd it's an acceptable loss. Having to click through a bunch of stuff to change volume is driving me crazy, though.

Googling suggested that it /may/ be a Pulseaudio/ALSA conflict, but the hardware keys seem to change at least indicated volume in pavucontrol for HDMI as expected (I don't have an HDMI cable to test actual sound output)

share|improve this question
add comment

3 Answers 3

up vote 8 down vote accepted

I got a clue somewhere to look in Settings / Settings Editor (not the normal Settings Manager)

Then, under xfce4-mixer, there was the setting /active-card which had the value:

PlaybackHighDefinitionAudioControllerDigitalStereoHDMIPulseAudioMixer

I selected 'active-card', and hit the 'Reset Property' button. That turned the setting into:

PlaybackBuiltinAudioAnalogStereoPulseAudioMixer

( These names closely follow the names of the Output Devices in pavucontrol see screenshot )

After a reboot, it worked. My volume buttons now affect the volume in the speakers.

(Scrub my earlier, now deleted, hint/comment about Play/Pause not working. They (still) work fine in Rhythmbox - that was/is an unrelated problem with gmusicbrowser)

This may or may not work for you! :-)

EDIT: For some reason, my xfce profile got corrupted and I've restarted from scratch by rm -rf ~/.config. Now, only a few days later, resetting it didn't work for me either, but setting /active-card to PlaybackBuiltinAudioAnalogStereoPulseAudioMixer did.

EDIT: If the above did not work try setting this via terminal and xfconf, e.g.

    xfconf-query -c xfce4-mixer -p /active-card -s 'PlaybackBuiltinAudioAnalogStereoPulseAudioMixer'
share|improve this answer
    
This worked perfectly! No idea why the system thought HDMI should be my default, but I reset those values, rebooted, and now my media hotkeys are working perfectly, no configuration required. –  Ruth May 10 '12 at 0:40
    
Cannot edit or create new string, field always resets to "HDAudioGenericAlsamixer". Consequently no volume hot keys work at all. –  fleamour Jun 26 '12 at 12:30
    
Had to kill xfce4-volumed process, before changing value, otherwise keeps resetting string field. Result! –  fleamour Jun 26 '12 at 13:23
    
Thank you very much for this! My volume control keys were not working either but now they are fixed. I would just like to let people know that if your language is set to non-US spelling then you need to add the 'ue' to the end of analogue: PlaybackBuiltinAudioAnalogueStereoPulseAudioMixer –  user97490 Oct 14 '12 at 0:29
    
From suggested edit: If the above did not work try setting this via terminal and xfconf, e.g. xfconf-query -c xfce4-mixer -p /active-card -s 'PlaybackBuiltinAudioAnalogStereoPulseAudioMixer' –  hexafraction Nov 4 '12 at 23:40
show 2 more comments

This fix will also fix the volume control on the Logitech G930 Wireless gaming headsets. (Not sure about the other buttons though) Launch Settings / Settings Editor (not the normal Settings Manager) or open a command prompt and type xfce4-settings-editor

Then, under xfce4-mixer And replace the active-card setting marked Value: to

PlaybackLogitechG930HeadsetAnalogStereoPulseAudioMixer

I've included an image to make it easier to understand

Also if have problems with the headset volume working here's a link that may help https://bugs.launchpad.net/xfce4-volumed/+bug/901338

Basically do a killall xfce4-volumed and try moving the volume on the headset again

headset

share|improve this answer
add comment

Peters answer also worked for me. However resetting the /active-card deleted the entry. I just added it again:
name: /active-card
type: string
value: PlaybackBuiltinAudioAnalogStereoPulseAudioMixer

Rebooted and I did get an crash-report from /usr/bin/xfce4-volumed, but the controls work again.

Thanks!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.