Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It was ok in the past but something has broken some months ago and my bank client authentication Java applet stopped working. Now I have to reboot to Windows and use it from there. I have installed (and am using for different purposes) Oracle JDK (manually, from official Oracle distribution files) on XUbuntu but I think Firefox Java plugin still uses OpenJDK. How to set up and make sure Firefox to use a specific Oracle JDK?

share|improve this question
    
Hi - you didnt mention which version of the JDK you use - however, have a look at this to see if this Q&A helps: askubuntu.com/questions/67909/how-do-i-install-oracles-jdk-6 –  fossfreedom May 3 '12 at 19:29
add comment

1 Answer

Thanks to @fossfreedom, I've set up Firefox to use Oracle JDK as follows:

  1. I've removed IcedTea plugin. Curiously, "apt-get remove" said it is not installed but Synaptic helped.

  2. Then I've made a link with

    ln -s /opt/jdk/jre/lib/i386/libnpjp2.so ~/.mozilla/plugins/

  3. At this point it was looking like Java plug-in is installed (shown in Firefox's plug-ins list and showing no error pop-ups on applet pages) but it didn't work actually: an animated java logo symbol was appearing instead of applets.

  4. Then I've tried to open my banking applet and was asked if I trust Oracle Java. After confirming this Java applets began to work fine on all the pages.

Unfortunately this haven't solved my actual problem - banking still doesn't work (fails to log-in with correct key file and password).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.