Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Eclipse from the Software Center in Ubuntu 12.04 LTS, and then setup PyDev from there. The application itself seems to be working okay, but its launcher icon shows no carets or other indication that it is already running. Also, Eclipse does not show up when I hit 'alt+tab' to cycle between open applications. It does show up when I hit 'super+tab', though.

Any ideas?

Monte

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Unity may still have problems with Java applications like:

  • Open/LibreOffice
  • IntelliJ idea
  • eclipse
  • rssowl

especially when switching window-hints and floating tool bars are involved. It might help to try another, more standards-conforming window manager, like xfwm4 or metacity.

share|improve this answer
    
For the most part... this concurs with what I've since found in searches 'round the net. Oddly enough... I just now re-installed Eclipse (re-installed the OS for another reason)... and the Eclipse icon shows up fine on the Dock? –  memilanuk May 10 '12 at 22:12

I had the same symptoms, though a different set-up. (See at the bottom.) This appears to be fixed now. The key was to disable Unity's application switcher and re-enable compiz's static switcher (part of compiz-plugins package).

Warning - you can mess up your desktop doing this. Don't try it when there is a possibility you will accidentally click on the wrong thing (due to using a laptop track-pad or (like me) having toddlers who may randomly mash your keys before you can stop them). Don't try it if you are not capable of fixing a locked-up machine if things go wrong. Caveat Emptor. See: What are some of the issues with ccsm and why would I want to avoid it?

Here are the steps I took:

  1. sudo apt-get install compizconfig-settings-manager compiz-plugins

  2. Alt+F2. Type ccsm

  3. Disable the keyboard shortcuts for Unity's switcher by unchecking the following check-boxes in CompizConfig Settings Manager ▸ Desktop ▸ Ubuntu Unity Plugin ▸ Switcher:

    • Key to start the switcher ▸ Enabled
    • Key to start the switcher in reverse ▸ Enabled
    • Key to start the switcher for all Viewports ▸ Enabled
    • Key to start the switcher in reverse for all Viewports ▸ Enabled
  4. Enable the Static Application Switcher by checking CompizConfig Settings Manager ▸ Window Management ▸ Static Application Switcher ▸ Enable Static Application Switcher

    • There shouldn't be conflicts if I remembered all the ones had to resolve. However, if there are key-conflicts, remove the one for the unity plug-in.
    • There was quite a delay (30 seconds-1 minute) during which my machine was unresponsive while the static switcher enabled. Don't click on anything during this time, the clicks will be cached and played back.

My answer is indebted to the accepted answer to: How do I revert Alt-tab behavior to switch between windows on the current workspace?

The difference in my setup was that I installed Eclipse Indigo /Java EE manually (with my own .desktop file) and did not install Py/Dev, but I was having the same problems - no carets on the Unity launcher, and Eclipse did not appear in Alt-tab - the only way to switch to it was Super-W.

share|improve this answer

I am having the same troubles with IntelliJ and SQLDeveloper. It may because they are launching using a shell script? Spotify acts similar in that it shows the caret in the launcher but is not working with alt-tab.

share|improve this answer

If you also have a portable install in /opt, and you launch that as well, it breaks AltTab and Dash integration. It works fine for me from repo with pydev via the Aptana-studio plug-in.

Note: I also have it pinned to the launcher.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.