Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

vdpau seems to be broken in Precise under Unity 3d. CPU usage ranges around 50-70% for 1080p movies while same movies utilizes around 5-10% in Natty with vdpau enabled (under Unity3d) The card is Nvidia G105m.

It doesn't seem to be a Nvidia driver problem because in gnome-shell everything works as expected and I have tried different versions of Nvidia drivers (295.20, 295.33, 295.40 and the latest 302.XX from xorg-edgers) The results are all the same, works in Gnome Shell but not in Unity 3d.

Disabling syn to vbank works if movie is not in full screen mode, but it doesn't work for full screen.

I have searched around and haven't found much info. I am wondering if others are experiencing the same problem and if there are some known work around that I have missed. Unity 3d is otherwise very nice in Precise, but this is a show stopping issue for me (literally).

Thanks.

I have filed a bug here https://bugs.launchpad.net/unity/+bug/993397

share|improve this question
    
same problem on ION 330 hardware in 12.04. Probably it is a compiz bug ... –  Postadelmaga Jul 16 '12 at 17:53

2 Answers 2

That sort of CPU usage suggests that it's not using VDPAU at all. Even on a rubbish Atom+ION PC I'm only seeing 0.1-0.2 loads when playing 1080p. I suggest you double-check to make sure VDPAU is running.

This can fairly quickly be done with mplayer. Just run mplayer video.mp4 (making sure it's a codec that can be decoded by VDPAU) and you should see something like this in the output:

Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))

If you're not, check libvdpau1 is installed.

share|improve this answer
    
It is running because it works in Gnome Shell (5%-7%) and also, if I disable vdpau in mplayer the cpu usage shoots up to over 100%, so even in Unity 3d vdpau is working, just horribly. As said, if I disable sync to vbank then I get the 5%-7% for non full screen movies. –  bowser May 3 '12 at 16:31
    
libvdpau1 and vdpau-va-driver are both installed and I do see the output ffh264vdpau... So everything seems to be in order but cpu load is still huge in Unity. –  bowser May 3 '12 at 16:46

From what i know, there are 2-3 issues for some nvidia graphics:

  • sync to vblank - deselect this option
  • detect refresh rate - deselect this option and set your refresh rate manually
  • vdpau

Here's a post about it

http://tombuntu.com/index.php/2009/09/20/make-compiz-run-smoothly-and-without-tearing/

** In the article it says to select sync to vblank: try to see if enabling / disabling has an effect.

Hope this helps someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.