Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed 12.04, but the sound is not working from both internal speakers, and from headphones when I connect them.

I have followed the instructions at https://wiki.ubuntu.com/DebuggingSoundProblems to no avail and submitted a bug report. I've also tried running alsamixer and unmuting a few more things, but that didn't work.

I've tried to upgrade alsa sound drivers by running:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get install linux-alsa-driver-modules-$(uname -r)

however on the last command:

$ sudo apt-get install linux-alsa-driver-modules-$(uname -r)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-alsa-driver-modules-3.2.0-24-generic-pae
E: Couldn't find any package by regex 'linux-alsa-driver-modules-3.2.0-24-generic-pae'

What should I do to try get sound functioning?

It might be worth noting that 10.04 previously ran on this machine with no sound problems.

share|improve this question
    
tried changing the devices to correct option? –  Vineet Menon May 8 '12 at 6:24
    
@VineetMenon yeah, I have. –  oadams May 8 '12 at 9:01
1  
If you type pulseaudio into your terminal do you get this message ? E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_create() failed. –  bibismcbryde May 9 '12 at 3:32
    
Install Gnome alsa Mixer. Set the master control to its Maximum. Check your hardware too. Look at this also - askubuntu.com/questions/24722/no-sound-after-boot –  Curious Apprentice May 9 '12 at 3:38
    
yes, I do get that message. –  oadams May 9 '12 at 3:53
show 3 more comments

2 Answers 2

up vote 6 down vote accepted

What solved this problem in my case was posted over at the Ubuntu Forums.

Append /etc/modprobe.d/alsa-base.conf with the following line:

options snd-hda-intel model=generic

Then restart your Ubuntu system.

share|improve this answer
    
I had a similar problem. I tried changing the alsa-base.conf file, but with no luck. What did work for me was adding snd-hda-intel to the end of the etc/modules file, as recommended here: ubuntuforums.org/showthread.php?t=1961136 –  Keidax Sep 23 '12 at 21:14
add comment

Just delete / rename the hidden file and folder .pulse and .pulse-cookie and then reboot.

If that doesn't work, try to install the package pavucontrol

share|improve this answer
    
Unfortunately that didn't work. pavucontrol is also already installed and running that and changing settings didn't work :( –  oadams May 9 '12 at 2:58
    
This one worked for me, but my sound stopped working after some sectors of my hard disk (/home partition) were recovered. –  Alberto de Paola Aug 5 '12 at 23:49
add comment

protected by Community May 12 '12 at 13:52

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.