Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Lubuntu 12.04 and was wondering if there was a way to keep it from locking the screen when the screensaver starts?
The "lock screen after X minutes" box is unchecked, so that is not causing the problem. Does anyone know the solution for this problem? I'm not worried about security, so i don't need it locked.

share|improve this question

3 Answers 3

I recommend you simply remove xscreensaver by typing sudo apt-get remove xscreensaver This will solve your problem, if you don't need a screensaver, your screen still turns black by your energy safe settings.

share|improve this answer
    
Granted most screensavers dont do what they need to. moire2 is a good example of ones that do work. screen burn in is still a problem even on lcd's I have a pc that the right monitor is rotated and has a scroll bar on the right side of the screen about 12-16 hrs a day. I set the screen saver for 10 min and blank for 20 so that moire can excersize out that scroll bar burn in. after about 3 months of use like that you could easily see where the scroll bar and other buttons were due to burn in. –  Kendrick Oct 21 '12 at 17:31

I think you have to disable the "lock" in two different places. First, open the power manager. You can click on the power icon in the panel and select "preferences" or it should also be in Menu -> Preferences -> Power Manager

http://dl.dropbox.com/u/35272968/site/2012-06-15-192224_740x482_scrot.png

De-select "Lock screen...." under the "Extended" menu tab.

Second, open screensaver preferences. Menu -> Preferences -> Screensaver.

Again, de-select "lock screen..." at the bottom of the window.

CREDIT: http://lubuntutips.blogspot.com/2012/06/lubuntu-screensaver-lock.html

share|improve this answer

For default setup of Lubuntu 14.04, the locking can be disabled via Preferences -> Light Locker Settings. In my case, "Automatically lock the session" was "Never", yet the session was still being locked after around 10 mins of inactivity. So I turned "OFF" the "Enable light-locker" setting, which did the thing for me. I also disabled all "locks" in Power Management as in @algebralives's answer. Don't know if it was required, but definitely not sufficient.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.