Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I upgraded from Ubuntu 11.10 to Ubuntu 12.04 (64 bit). The upgrade went smoothly (far more than I expected). Unfortunately, I cannot seem to install the flash plugin in either Firefox or Chrome.

chrome://plugins

does not show flash. I tried

19:17farhat ~$ sudo apt-get install flashplugin-installer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
flashplugin-installer is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Yet, I cannot seem to find anything related to flash on the system.

19:17farhat ~$ sudo updatedb
[sudo] password for farhat: 
19:17farhat ~$ locate libflashplayer.so
19:17farhat ~$ locate libflashplayer
19:17farhat ~$ locate libflash
/usr/lib/libreoffice/program/libflashlo.so
19:17farhat ~$ 

I am at the end of everything I know. Any help will be appreciated. I have tried removing and reinstalling the package. Still the same results.

share|improve this question
    
It's connected with launchpad bug 1052377 bug, please vote "this bug affects me to" –  user108128 Nov 14 '12 at 22:16
add comment

5 Answers

Open terminal via Dash (Dash then type in Terminal, click on it). Then type in the following two commands:

sudo mkdir /opt/google/chrome/plugins
sudo ln -s /usr/lib/flashplugin-installer/libflashplayer.so /opt/google/chrome/plugins

Restart chrome

When sudo prompts for your password, type it in, it won't show up, so remember what you type in.

share|improve this answer
add comment

Actually, the solution was provided by Farhat in a comment. Here is a step-by-step instruction.

  1. sudo su
  2. export http_proxy="http://address.to.my.proxy/"
  3. apt-get remove flashplugin-installer
  4. apt-get install flashplugin-installer
share|improve this answer
    
A more elegant way to get a root shell, using just sudo, is sudo -s. –  Eliah Kagan Jun 20 '12 at 11:57
add comment

Chrome uses its own built-in version of Flash, so I have no idea why it doesn't work. As for the other programs, try reinstalling flashplugin-installer.

  • sudo apt-get remove flashplugin-installer
  • sudo apt-get install flashplugin-installer

Perhaps the update broke or removed some files.

share|improve this answer
1  
It was an issue with proxy settings not getting transferred under sudo. It worked after I used a root shell with 'export http_proxy=...'. I feel if the install does not complete due to such a reason apt-get should not say the package has been installed and refuse to reinstall it. –  Farhat May 4 '12 at 7:25
1  
It's advisable to run sudo apt-get update before (re)installing packages from the command line (this updates the local database of what software is available, in what versions and from where). Also, you can reinstall software with one package management step using sudo apt-get --reinstall install flashplugin-installer. You can reinstall it, removing all configuration files during the removal process, using sudo apt-get --purge --reinstall install flashplugin-installer. –  Eliah Kagan Jun 20 '12 at 11:59
add comment

For Firefox, there is a plugin that works wonders; I found out about it from the Reddit Ubuntu forum, and I believe it was written by a Redditor. flash-aid.

share|improve this answer
    
removed by it's author –  BЈовић Apr 9 at 7:26
add comment

Did you install the package called ubuntu-restricted-extras? You can do this in the Software Center or, if you prefer the to use the command-line, then by running

sudo apt-get update 

followed by

sudo apt-get install ubuntu-restricted-extras
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.