Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 10.04 in my MAC using virtual box. I mounted two of my folders in MAC using virtual box. But the problem is, I created my shared folder called "share" inside /mnt.

How do I get the Share folder to appear on the desktop and how do I get it to auto-mount on start-up?

share|improve this question

migrated from stackoverflow.com May 3 '12 at 12:34

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 0 down vote accepted

auto mount on startup should be a virtualbox setting when you set up the share , you will need guest additions installed to use the share i believe.

you could simply link the directory from /mnt to your desktop

this would be done in the terminal by typing

ln -s /mnt/share ~/Desktop

you may need to try sudo !! if it's denied.
or I'm sure there's an option to show network servers on desktop , most likely in your desktop settings , I don't remember 10.04 well

share|improve this answer
    
i managed to link the directory to my desktop, but can't get it to mount automatically on start-up. While creating the shared folders in virtual box, i checked the "mount automatically" check-box(not sure if this is what you said i had to do) . I got to know that i have to add a line in the fstab file located in /etc to auto mount on start-up. This is the command i used to mount my folder "mount -t vboxsf Assignments share " where share is the folder that i created in the /mnt folder. Could anyone tell me what line am i supposed to include in the fstab file? –  hektor May 4 '12 at 6:34
    
i think this may need to be posted as a new question. but yes thats exactly right i meant auto-mount in vbox's options ,i'm not sure what you need to add fstab though –  MuffinStateWide May 5 '12 at 1:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.