Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am experiencing a problem trying to login with lightdm: lightdm hangs after I insert password with message "loggin in". I've tried to restart it but the only workaround I've found is to reboot several times or as a temporary fix use gdm.

Thanks

Edit: there's some talking about this in https://bugs.launchpad.net/unity-greeter/+bug/986967 and it seems that, if login sound is disabled, fix is being released on precise-proposed updates

share|improve this question
add comment

closed as off topic by fossfreedom May 22 '12 at 18:38

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Really, I didn't found the solution with lightdm, but replacing it with GDM helped. Could you try it and share whether it helped or not?

Sorry for my English.

share|improve this answer
add comment

Since you can see lightdm I think this is more a lightdm and no plymouth problem.

A bunch of people have similar problems like you. Maybe one of these links can help you:

https://bugs.launchpad.net/lightdm/+bug/986967 (Launchpad Bug which sounds like your (and mine) problem)

similar questions here on askubuntu:

Ubuntu 12.04 Hangs On Login

Stuck at login screen (with a detailed answer on how to switch to gdm as workaround)

12.04: LightDM freezes while "Logging in..." - maybe due to deactivated login sound

edit: There is a bugfix on it's way which is already available in the precise-proposed repository. You can read here how to use it.

edit: People in Launchpad report that the bugfix is working, and that the problem may be caused by deactivating the login sound with Ubuntu Tweak. Maybe reactivating the login sound might fix this problem too until a official update is available

share|improve this answer
    
I saw.. Someone says it's a mix of issues (in my case every time it happens plymouth has failed to do mountall). By the way next time I'll try gdm. –  unsel May 3 '12 at 19:00
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.