Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu on my Dell 1555 Laptop and decided to make it dual boot with Windows 7. I wanted to share the home folder with the "My Documents" Folder in Windows, so i created an extra partition for this folder. Sadly, the ext3 partition didn't showed up, so i decided to format it to NTFS. Now, everything works just fine, but the audio fails. I can hear sound, but i can't change the volume. Neither on the Unity bar nor in the audio settings. On the bar, the speaker symbol has just three dahses behind it, the settings are greyed out. Also, my soundcard won't show up in the settings...

After some reading i think i found out, that pulseaudio fails to start. It gives me that:

    user@user-Laptop:~$ pulseaudio --start
    E: [autospawn] core-util.c: Home directory /home/user not ours.
    W: [autospawn] lock-autospawn.c: Fehler beim Zugriff auf Autostart-Sperre.
    E: [pulseaudio] main.c: Failed to acquire autospawn lock

So i did:

    user@user-Laptop:~$ ls -l /home/
    insgesamt 12
    drwxrwxrwx 1 root root 4096 Mai  1 16:00 Benutzer
    drwxrwxrwx 1 root root    0 Mai  1 15:58 $RECYCLE.BIN
    drwxrwxrwx 1 root root    0 Mai  1 15:48 System Volume Information
    drwxrwxrwx 1 root root 8192 Mai  3 12:14 user

I think my problem is, that i must be the owner of the home folder

    chown -R user /home/user/.dmrc
    chmod 600 /home/user/.dmrc
    chown -R user /home/user
    chmod 755 /home/user

Sadly, this won't work too. So I came up with adjusting the fstab:

    # /home was on /dev/sda4 during installation
    UUID=493A893161C9A186    /home    ntfs-3g    defaults, nls=utf8, umask=077, uid=user, gid=users, usermapping=/home/, dmask=002    0    0

I listed usermapping=path in the options, because i've read that there is a usermapping on each NTFS Partition, located in a hidden folder ( .NTFS-3G ). But this folder doesn't exists too.

In order to repair my audio, i created .xinitrx and .xsession for pulseaudio. I don't know if this helps anyone...

So for conclusion: All i want is to adjust my audio volume, everything else is working afaik

share|improve this question
add comment

1 Answer

As it is possible to share data such as documents, pictures, video or music files on a NTFS filesystem we can not do so for the whole /home partition.

Unlike standard Ubuntu file systems (e.g. ext4) NTFS is unable to handle our file permissions. This may lead to issues with applications not being able to read or write their settings located in a /home subdirectory. Pulseaudio is only one example here, you will likely see other similar errors.

Let me therefore suggest you put the /home directory in a standard Ubuntu file system (e.g. ext4) and put only those data files that need to be shared with windows on a NTFS formatted partition. You will still have access to these data from Ubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.