Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to upgrade my server (using do-release-upgrade -d, as one currently has to when going from 10.04 to 12.04), the script froze, and I was forced to cancel it. I was left with a half 10.04, half 12.04 system, but was able to upgrade most of it manually using aptitude upgrade --full-resolver.

I am now at a point where it will boot no problem, and most of my applications are installed correctly, but there are a few packages which just will not install. I've tried apt-get install -f, apt-get purge, dpkg-reconfigure -a, and I just can't think of anything to do.

root@NCLI-SERVER:~# apt-get install -f
Reading package lists... Done
Building dependency tree      
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
16 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up fontconfig-config (2.8.0-3ubuntu9) ...
rmdir: failed to remove `/var/lib/defoma/fontconfig.d/': Directory not empty
dpkg: error processing fontconfig-config (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libfontconfig1:
 libfontconfig1 depends on fontconfig-config (= 2.8.0-3ubuntu9); however:
  Package fontconfig-config is not configured yet.
dpkg: error processing libfontconfig1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgd2-xpm:
 libgd2-xpm depends on libfontconfig1 (>= 2.8.0); however:
  Package libfontconfig1 is not configured yet.
dpkg: error processing libgd2-xpm (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgphoto2-2:
 libgphoto2-2 depends on libgd2-xpm (>= 2.0.36~rc1~dfsg); however:
  Package libgd2-xpm is not configured yet.
dpkg: error processing libgphoto2-2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsane:
 libsane depends on libgphoto2-2 (>= 2.4.10.1); however:
  Package libgphoto2-2 is not configured yet.
dpkg: error processing libsane (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of colord:
 colord depends on libsane (>= 1.0.11-3); however:
  Package libsane is not configured yet.
dpkg: error processing colord (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpoppler19:
 libpoppler19 depends on libfontconfig1 (>= 2.8.0); however:
  Package libfontconfig1 is not configured yet.
dpkg: error processing libpoppler19 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgs9:
 libgs9 depends on libfontconfig1 (>= 2.8.0); however:
  Package libfontconfig1 is not configured yet.
dpkg: error processing libgs9 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups-filters:
 cups-filters depends on libfontconfig1 (>= 2.8.0); however:
  Package libfontconfig1 is not configured yet.
 cups-filters depends on libpoppler19; however:
  Package libpoppler19 is not configured yet.
dpkg: error processing cups-filters (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcairo2:
 libcairo2 depends on libfontconfig1 (>= 2.8.0); however:
  Package libfontconfig1 is not configured yet.
dpkg: error processing libcairo2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of poppler-utils:
 poppler-utils depends on libcairo2 (>= 1.10.0); however:
  Package libcairo2 is not configured yet.
 poppler-utils depends on libpoppler19; however:
  Package libpoppler19 is not configured yet.
dpkg: error processing poppler-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups:
 cups depends on poppler-utils (>= 0.12); however:
  Package poppler-utils is not configured yet.
 cups depends on cups-filters; however:
  Package cups-filters is not configured yet.
dpkg: error processing cups (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of printer-driver-gutenprint:
 printer-driver-gutenprint depends on cups (>= 1.3.0); however:
  Package cups is not configured yet.
dpkg: error processing printer-driver-gutenprint (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ghostscript:
 ghostscript depends on libgs9 (= 9.05~dfsg-0ubuntu4); however:
  Package libgs9 is not configured yet.
dpkg: error processing ghostscript (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gs-cjk-resource:
 gs-cjk-resource depends on ghostscript (>= 8.70~dfsg-2.1); however:
  Package ghostscript is not configured yet.
dpkg: error processing gs-cjk-resource (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ghostscript-cups:
 ghostscript-cups depends on ghostscript (>= 8.64~dfsg-8); however:
  Package ghostscript is not configured yet.
dpkg: error processing ghostscript-cups (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 fontconfig-config
 libfontconfig1
 libgd2-xpm
 libgphoto2-2
 libsane
 colord
 libpoppler19
 libgs9
 cups-filters
 libcairo2
 poppler-utils
 cups
 printer-driver-gutenprint
 ghostscript
 gs-cjk-resource
 ghostscript-cups
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
    
Why not try and clear your cache? I don't know if that will cause any critical problems but its worth a try. –  harisibrahimkv May 3 '12 at 10:22

1 Answer 1

From the start of your log:

rmdir: failed to remove `/var/lib/defoma/fontconfig.d/': Directory not empty

Try to delete all files in this dir, after all the dir is going to be removed by the update, so no harm seems possible:

rm /var/lib/defoma/fontconfig.d/*
share|improve this answer
2  
+1. When you're hacking away at trying to fix upgrade issues, following the error messages should let you fix things up. –  Oli May 3 '12 at 10:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.