Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My graphics card is not recognized in system info, It is an onboard GMA 965gm (or x3100), but i can still play games which require 3D acceleration. How can i correctly install the drivers?

Thank you

EDIT: It runs on ubu 12.04

After running the lspci -v command it came up with the following The os is 12.04.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03) (prog-if 00 [VGA controller])
    Subsystem: Apple Inc. Device 00a1
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at 90100000 (64-bit, non-prefetchable) [size=1M]
    Memory at 80000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 6110 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: intelfb, i915


00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)
    Subsystem: Apple Inc. Device 00a1
    Flags: bus master, fast devsel, latency 0
    Memory at 90200000 (64-bit, non-prefetchable) [size=1M]
    Capabilities: < access denied >

It seems to my noob eyes that the card is recognised, but it doesnt show up in system settings nor in the additional drivers.

share|improve this question
    
Your system info question will be resolved by this Q&A: askubuntu.com/questions/85318/… –  fossfreedom May 3 '12 at 11:24
add comment

3 Answers

Welcome Thomas! Run "Additional Drivers" and install the one recommended and reboot your Ubuntu.It may help you.

share|improve this answer
    
Great idea.I have already done that Beeju but unfortunately, it didnt come up with any additional drivers apart from my wireless card. –  Thomas May 3 '12 at 9:29
    
Pls include more specification about your system and Ubuntu version.Could u pls include the image of "Additional drivers" application? Type lspci -v in terminal and give the output of your video card here. –  beeju May 3 '12 at 9:36
add comment

Intel i915 driver module, which should recognise your graphics chipset, should be loaded in kernel by default. Probably that's why it's not listed in Additional driver.

What is the output of the command lsmod | grep i915? If it's returning i915 that means the module is already loaded and working.

If not then open /boot/grub/grub.cfg and check if the kernel line (the line which is started with linux /boot/vmlinuz..) has the parameter i915.modeset=1. If not or if the line has parameter nomodeset then open /etc/default/grub and edit the following line as

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1" then reboot. See if that works.

share|improve this answer
add comment

try installing

sudo apt-get install mesa-utils

this fixed it for me with a slightly different onboard graphics card, but I believe it's universal. You can always remove it!

sudo apt-get purge mesa-utils

source

How Do I Install Intel HD Graphics Driver on Ubuntu 12.04?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.