Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I shutdown my computer and today when I powered it on and logged in to 12.04, certain strings are in Japanese/Chinese (I don't know how to differentiate between the two). The strings are:

  1. Applications, places menu selector in my panel.
  2. Under 'places', the 'Home folder', 'Desktop', 'Computer'.
  3. The menus in VLC!
  4. Certain applications like 'sound converter', etc.

How can I change everything back to English?

I'm using Gnome classic in Ubuntu 12.04.

share|improve this question
    
    
Divad, Bless you for not assuming everyone can navigate the system in Chinese (Urdu, Farsi...) This is far and away the best answer I've seen on the topic. Fixed me at 6 am ;-) –  user290537 Jun 8 at 6:29
add comment

3 Answers 3

up vote 11 down vote accepted
  1. Edit /etc/default/locale:

    LANG="en_US"
    
    LANGUAGE="en_US:en"
    
  2. Edit ~/.pam_environment:

    LANG=en_US
    
    Language=en_US
    

Log out and log in, or reboot.

share|improve this answer
    
Can you please enlighten us as to why this happens? Today I woke up with the same problem. Since I started learning Japanese I installed the Japanese language support (no other way around to just add Japanese layout and you have to switch to ibus in order to use it). I was quite shocked when without my permission my system turned against me. I have pretty basic knowledge in this language and the fact that Dash responded only to Kanji and stuff like was an overkill for me. LOL /etc/default/locale was as it was (correct, that is) but ~/.pam_environment had added "ja" (Japanese). –  rbaleksandar Sep 22 '13 at 6:29
add comment

Okay, so i stumbled across the post as I had the same problem. Hopefully this will help a bit, as it worked for me:

  1. open a terminal as your primary user. This can be done by menu or pressing Ctrl+Alt+t from the desktop.

  2. Type 'sudo su' without the 's. (that is, type: sudo su)

  3. When the terminal prompts for your password, enter it and press enter.

  4. type 'gnome-control-center', againt without the 's, and press enter

  5. The control center should now open and you click on the blue flag (Looks kind of like the UN-flag).

  6. It will most like pop-up with a question in chinese (Incomplete language support). Just push the left button - after the chinese writing it says '(R)' according to my memory.

  7. Now you're at language support. Here you will see a list of languages. Mine was, in decending order: Something chinese, English, a lot of Greyed-out English accents. Here you have to drag he chinese one down the list (It disappeared when I tried), leaving English as the top one. This step may take a few tries. Don't worry, it will work ;-)

  8. Press the button below the list, this says "Apply system wide" in chinese. It may prompt for your password. It so, enter it.

  9. Now you can close the Language support window and log out as usual. When you log in, language should be back to english.

Cheers, DivadLarsen

share|improve this answer
add comment

Run "language support" from dash and select "English" and click "apply system wide".This should work for you.

share|improve this answer
    
I'm sorry but I'm using Gnome classic and I don't have dash. –  harisibrahimkv May 3 '12 at 9:22
    
If u r from gnome, then System>Preference>Language support.Moreover u can select the default language from the bottom panel of login menu. –  beeju May 3 '12 at 9:24
    
First of all, my login menu did not have a bottom panel and I have already searched on that screen for language preferences which I was not able to find. Secondly, my System->Preferences does not have 'language support' as an option in it! –  harisibrahimkv May 3 '12 at 9:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.