Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Whenever I close my laptop's lid, it locks and I have to enter my password to get it to resume. In my power settings, I have selected "Do nothing" for the option "When lid is closed" for both "On battery power" and "When plugged in" state.

What's going on?

share|improve this question
I think the problem might be confusion over what the terms "suspend" and "resume" means. "Suspends" means your computer goes into sleep mode. "Resume" means waking it up. What you mean is that you need to enter your password to unlock the screen. I think you're just referring to the screensaver coming on and locking the screen, which is a different setting than the ones you're looking at. –  Chan-Ho Suh May 3 '12 at 9:03
Yeah, I probably worded that wrong. My main concern is that it requires to be resumed at all. I want absolutely nothing to happen when I close the lid. How can I do this? –  Wut May 3 '12 at 9:08
Look under screensaver settings. Uncheck the option to lock the screen. –  Chan-Ho Suh May 3 '12 at 9:14
I looked through everything under System Settings and there doesn't seem to be any other settings like this besides some settings under "Power" and "Brightness and Lock", which I've set to my desired outcome. –  Wut May 3 '12 at 9:21

2 Answers 2

I think completing the bug report from might get this fixed. Thanks!

share|improve this answer
this derivative one as well:… –  HDave Jul 30 '12 at 4:39

Possible workaround: In System Settings > Brightness and Lock switch off 'Lock'. The downside is that your system also cannot lock anymore after a set time.

share|improve this answer
Thank you, this is a good work around. –  Kevin Duke Aug 10 '12 at 0:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.