Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

good morning,

lightdm freezes often after I entered my passwort. It hangs exactly saying "logging in...". It's no total system breakdown though.

I found out that there is already an existing bug report for that problem which affects a lot of people: https://bugs.launchpad.net/lightdm/+bug/986967

some people in Launchpad report that the problem may be caused by deactivating the login sound with Ubuntu Tweak. I've done that so it might be true.

There are 3 dupiclate question for this problem on askubuntu too:

Ubuntu 12.04 Hangs On Login

12.04 Lightdm cannot login

Stuck at login screen

share|improve this question
    
Maybe it's the same problem like this: askubuntu.com/questions/130387/stuck-at-login-screen –  panmari May 3 '12 at 7:59
    
Yeah, it seems to me. I have the same error output you posted in your question. Do you also have the dbus error in your auth.log when the login gets stuck? –  rearlight May 3 '12 at 9:23
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  fossfreedom May 22 '12 at 18:41
add comment

closed as off topic by fossfreedom May 22 '12 at 18:41

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

i had the same problem, i installed gdm and logins in gdm than lightdm. light dm is a bug-gy. for this at main login crtl+alt+f1 and sudo there and apt-get install gdm and activate it

share|improve this answer
    
thanks for your help. but I will stick to lightdm a little longer if that bug isn't to annoying. gdm is more like a workaround so I hope this bug will be fixed soon –  rearlight May 3 '12 at 20:58
    
lightdm is indeed not very robust, I triggered the login hang by applying the greeter numlockx fix without installing numlockx, that was enough to stop lightdm dead and throw the system into low-graphics mode! –  prusswan Jun 17 '12 at 21:37
add comment
up vote 2 down vote accepted

Until the official bugfix will be released - which should be soon - there are several ways to fix this problem:

  1. Reactivating the login sound with Ubuntu Tweak (worked for me)

  2. Installing the official bugfix which is in the "precise-proposed" repository now. https://wiki.ubuntu.com/Testing/EnableProposed

  3. Switching to gdm as default display manager as indicated by sam until this problem is fixed.

  4. Changing nothing and doing the following when the problem occurs:

    1. Pressing Ctrl + Alt + F1
    2. Logging in as admin user
    3. sudo restart lightdm
    4. Trying to login in lightdm again
    5. Repeating 1., 3. and 4. until the login is successful

(I did a bit of research and I'm now able to answer my question myself. I hope it's no problem)

share|improve this answer
add comment

I noticed that it is linked to custom wallpapers. I changed to a custom wallpaper and Ubuntu couldn't log in. It would simply hang at "logging in".

Following the steps above, changing the wallpaper back to a default, it works fine.

This should really be fixed.

share|improve this answer
    
There is an official bugfix in precise-proposed now. So the problem should be solved soon. –  rearlight May 8 '12 at 5:51
add comment

I had the same issue after I added then removed the dodge feature from Unity (Ubuntu 12.04LTS 64bit)

This is what I did:

Using Synaptic Package Manager:

  1. Uninstalled Unity
  2. Uninstalled Lightdm
  3. Uninstalled Ubuntu-Desktop
  4. Re-installed Unity, Ubuntu-desktop, Lightdm

ALT + F2

unity --replace

I also reinstalled my Nvidia Graphic Drivers, has in the past caused issues after updates

Rebooted and it all came back working.

I did find I was able to log into a second account on my PC fine, so I think my profile was broken.

I then set my profile to auto logon in the USER menu.

I think it may have something to do with 'colord' (system service to manage device colour profiles), I noticed it kept crashing. Auto logon seems to be a solution, but compromises security..

The above process worked for me.

Thanks

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.