Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to Linux but liking it so far. My symptom is that I have a machine which dual boots WinXP and Ubuntu -- internet works on WinXP, not on Ubuntu.

Some specs: Ubuntu 11.10; AMD Athlon 64 processor; Network Interface Card by Realtek (RTL-8139/8139C/8139C+); cable modem by Scientific Atlanta (2100R2).

The connectivity is Cable > Modem > PC (by DSL)

The first times I booted into Ubuntu from CD, could not connect to internet. After installing on HDD, and booting (not from CD), internet worked once, and never again.

Searching around, I decided to try editing /etc/network/interfaces

Used to read:

auto lo
iface lo inet loopback

Based on posts, I decide to change it to

auto lo eth0
iface eth0 inet dhcp
iface lo inet loopback

and run sudo /etc/init.d/networking restart

This gives me a message about the command being deprecated, and then hangs so I kill it. I reboot and now in the splash screen I see "Waiting for network configuration" then "Waiting up to 60 seconds for network configuration" then "Booting without full network configuration".

Reading more online, I decide to keep /etc/network/interfaces the same, and edit file /etc/NetworkManager/NetworkManager.conf:


managed=true    # It was originally false

This changed nothing.

When I run the command ifconfig -a:

eth0    Link encap:Ethernet  HWaddr 00:14:2a:03:f0:77
    inet6 addr: fe80::214:2aff:fe03:f077/64 Scope:Link
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000 
    RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    Interrupt:22 Base address:0xdf00 

eth0:avahi Link encap:Ethernet  HWaddr 00:14:2a:03:f0:77  
      inet addr:  Bcast:  Mask:
      Interrupt:22 Base address:0xdf00 

lo        Link encap:Local Loopback  
      inet addr:  Mask:
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:488 errors:0 dropped:0 overruns:0 frame:0
      TX packets:488 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:38880 (38.8 KB)  TX bytes:38880 (38.8 KB)

I find it weird that I have no inet address for first entry for eth0, and why two entries? Actually, I don't know if that's unusual. Reading further, I decided to try to force a static ip address, you can tell me if that makes no sense. I changed /etc/network/interfaces to read:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

and reboot. This didn't help a bit. Been searching everywhere. DHCP is supposed to just 'work'. What else to do?

A bit more info: when I run route:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         *              U     1002   0        0 eth0
link-local      *          U     0      0        0 eth0

And when I run sudo lshw -class network:

   description: Ethernet interface
   product: RTL-8139/8139C/8139C+
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 5
   bus info: pci@0000:02:05.0
   logical name: eth0
   version: 10
   serial: 00:14:2a:03:f0:77
   size: 10Mbit/s
   capacity: 100Mbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
   resources: irq:22 ioport:df00(size=256) memory:fddff000-fddff0ff

Well, I am mucking around in things I don't understand. Time to ask: any help is much appreciated! I am teachable.

share|improve this question

Looking around there have been many problems and few solutions with the RTL8139 NIC. Tried many many things and finally got it working. I believe only the last step I performed worked, but I don't know for sure so I include all steps below.

Based on advice at http:[double-forward-slash][triple w], I ran the following commands:

sudo mii-tool eth0 -F 10baseT-FD
sudo rmmod 8139too
sudo modprobe 8139too

Commands seemed to do something, but no output to the terminal. But no luck, so tried things from, and ran commands:

sudo ifconfig eth0 down
sudo rmmod 8139too
sudo insmod 8139too media=0x01

I got a complaint on running the last one, something about "8139too file not found", which makes sense -- I guess rmmod means remove module; and having run lsmod | grep 8139 before and after all the above commands, indeed, where I had two entries (including one for 8139too) I was left with only one entry (which starts with 8139cp).

But, still no luck.

Finally, following advice at, I booted into Windows XP, and did the following Right click My Computer > Hardware > Device Manager; Expand the network interface card section and double click the Realtek one; Look around for "Wake-on-lan after shutdown" option, and set to "enabled"; Reboot into Linux

!!WORKED!! 8)

share|improve this answer
+ 1 So I could read it later, when I do a restarting a computer ;) – Aleks Feb 13 '14 at 10:13

I think your system is loading the wrong driver. A solution to this problem might be here :

share|improve this answer
Thanks, the realtek site does say that the Linux driver for 8139 NICs is in the kernel default, and the page you refer me to hints that there may be issues with the driver for realteks 8168 NIC in the kernel -- so perhaps same with 8139. Since (s)he had luck just going to version 12.04, its what I will try next... – shpensive May 3 '12 at 16:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.