Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm stuck at the moment with an ubuntu that boots into an unusable white screen after upgrading from 11.10 to 12.04.

I've tried booting into safe X mode but it just throws me back to the safe menu every time. Restore previous graphics driver, use default graphics configuration and set up new graphics configuration all don't work either.

I've tried various methods of resetting the graphics from the command line, but none are working due to unmet dependencies. These cannot be fixed by doing the normal "apt-get -f install" because its saying there is a dpkg error in var/lib/dpkg/status (blank line relating to skype-wrapper). I haven't been able to find any other way to fix the dependencies yet.

Can someone please give me some advice on what to do, I really don't want to go the re install route.

share|improve this question
    
Same here, in my case is ATI graphic chip so I needed to reinstalling driver. –  Smile.Hunter Dec 27 '12 at 5:38

3 Answers 3

Did you try this one: http://www.samael.me.uk/2012/05/how-to-fix-nvidia-graphics-issue-in.html ? Maybe it helps. It is just a beta driver, however, available for 32-Bit at: download.nvidia.com/XFree86/Linux-x86/302.07/NVIDIA-Linux-x86-302.07.run and for 64-Bit at: download.nvidia.com/XFree86/Linux-x86_64/302.07/NVIDIA-Linux-x86_64-302.07.run

share|improve this answer
    
oops, sorry forgot to mention I'm using ATI –  RiaanZA May 3 '12 at 9:50

the simplest way to fix your dependency issue is to uninstall the offending program and then proceed with fixing it. It's quite possible that your video card drivers just haven't been fully installed, so this may fix things:

sudo apt-get remove skype-wrapper
sudo apt-get -f install
share|improve this answer
    
only problem is I can't use apt-get for anything since there are unmet dependancies. I kinda feel like I'm in a catch 24 situation :( –  RiaanZA May 7 '12 at 11:46

I too had trouble with the video display on a dual boot laptop with Nvidia 7150M/630M grahics. The display was incomplete and missing the top and side bars. Where I did manage to call up a window/frame, it was missing the control icons. Following the instructions on samael.me.uk site fixed the problem - many thanks to Samael. A different driver from that mentioned was needed; I downloaded it in Windows and used the recovery mode of Linux to get it into an easily accessible location.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.