Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem installing Lexmark X6675 driver on Precise and have problem.

The package has a blank line in Description field which wasn't a problem all the way up to Oneiric but it is a problem on Precise.

Extracting file: printdriver.te
Extracting file: lexmark-08z-series-driver-1.0-1.i386.deb
Extracting file: launcher.c
Extracting file: launcher
Extracting file: lsbrowser
Extracting file: lsusbdevice
Using dpkg installation
=============================
Execute: dpkg -i --force-architecture lexmark-08z-series-driver-1.0-1.i386.deb > /tmp/selfgz11978/pkg/files/dpkg_msgs

dpkg: error processing lexmark-08z-series-driver-1.0-1.i386.deb (--install):
 parsing file '/var/lib/dpkg/tmp.ci/control' near line 9 package 'lexmark-08z-series-driver':
 blank line in value of field 'Description'
Errors were encountered while processing:
 lexmark-08z-series-driver-1.0-1.i386.deb
=============================

=============================
Execute: rm lexmark-08z-series-driver-1.0-1.i386.deb

=============================
***** ERROR REPORT *****

Is there any way to work around it?

share|improve this question

2 Answers 2

up vote 6 down vote accepted

This is my solution with Lexmark x4650 driver. Adjust to your needs.

Please execute the commands one by one:

sudo apt-get install ia32-libs xz-lzma
wget http://downloads.lexmark.com/downloads/cpd/lexmark-08z-series-driver-1.0-1.i386.deb.sh.tar.gz -O lexmark-08z-series-driver-1.0-1.i386.deb.sh.tar.gz
tar xzvf lexmark-08z-series-driver-1.0-1.i386.deb.sh.tar.gz
./lexmark-08z-series-driver-1.0-1.i386.deb.sh --noexec --target lexmark
cd lexmark
tar xJvf instarchive_all
dpkg-deb -I lexmark-08z-series-driver-1.0-1.i386.deb
mkdir raw-lexmark-archive
dpkg-deb --raw-extract lexmark-08z-series-driver-1.0-1.i386.deb raw-lexmark-archive
sed -i "/^ $/d" raw-lexmark-archive/DEBIAN/control
cat raw-lexmark-archive/DEBIAN/control
dpkg-deb -b ./raw-lexmark-archive fixed-lexmark-08z-series-driver-1.0-1.i386.deb
sudo dpkg -i fixed-lexmark-08z-series-driver-1.0-1.i386.deb

To remove the package run:

sudo dpkg -P lexmark-08z-series-driver:i386

all works, but when you go to add the ppd files, it's in /home/lexmark/raw-lexmark-archive/usr/local/lexmark/08zero/ect

For the x4650, choose lx36-46.ppd

share|improve this answer

Based on the answer above: Download http://www.mediafire.com/?yowom7gh6vg4fzl - Install and enjoy Used 1.0.4 version.

Note: Not sure about copyright, I waive any copyright claims, the software is copyrighted to Lexmark.

share|improve this answer

protected by Community Apr 6 at 9:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.