Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using two monitors, the main resolution is 1920x1080 and the secondary is 1440x900. Everything seems to work fine (with default drivers, fglrx crashes bad), besides windows opening in the wrong monitor (even when the main is set correctly), but now what I am trying to fix is the wallpaper problem, here's an image to explain it easier:

the problem with the wallpaper
Click on the image to see a full resolution version

It also happens with gradients. The secondary monitor is physically aligned like in the image, lower than the other, the wallpaper on the main screen seems to keep the size of the lower resolution, and then it start at the correct resolution the last part at right.

Any way to fix this?

I am using Ubuntu 12.04 with Gnome-Shell 3.4.1, the vga is a Radeon HD 6950


I went to gnome-tweak-tool and disabled "Have file manager handle the desktop", now it looks ok on both monitors, but I can't have icons on my desktop, so I am still interested in solving it.


Disabling "Have file manager handle the desktop", in gnome-tweak-tool and then re-enabling it seems to work, but has to be done every time you turn on the PC.

share|improve this question
I have a similar issue while using three monitors. I've got a large wallpaper (7680x1600), and when I set it to "span", screens #1 and #2 get the first third of the wallpaper, and screen #3 gets the middle third. – Eric Lathrop May 15 '12 at 23:03
See… workaround for the same problem – user121309 Jan 10 '13 at 20:00

I think the easiest way to solve the problem is to install nitrogen.

Nitrogen will set a background on each monitor.

You would then run nitrogen --restore as a custom command at login.


share|improve this answer
Do you know if with nitrogen I can use that blue strips wallpaper that "changes throughout the day"? – jiomsa May 3 '12 at 14:30
Not sure, give it a try and let us know. – bodhi.zazen May 3 '12 at 18:00
Nitrogen only seems to be able to change the wallpaper on my leftmost screen (of 3 screens). It only changes the wallpaper when the dropdown has "Full Screen" or "Screen 2" selected. "Screen 1" and "Screen 3" do nothing. – Eric Lathrop May 15 '12 at 23:07
@Eric Lathrop ouch, I've not seen that behavior before, I suggest you file a bug report. – bodhi.zazen May 16 '12 at 3:28
@bodhi.zazen nitrogen --restore isn't working for me, any ideas how to troubleshoot this? Everything else works, I've disabled desktop icons and can run nitrogen and set the background no problem. I just can't get it working automatically at login. I have /home encrypted but shouldn't be an issue as it's mounted at login anyway. – Tom Brossman Dec 23 '12 at 14:08

You could add the following two entries in your .xprofile file. At a terminal type:

gedit $HOME/.xprofile

and add the following lines:

gsettings set org.gnome.desktop.background show-desktop-icons false
gsettings set org.gnome.desktop.background show-desktop-icons true

and then make the file executable

chmod +x $HOME/.xprofile

This will disable and enable this setting every time you login.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.