Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on a Macbook Pro 5,5 running 12.04 LTS, pommed v1.39, and Gnome Shell 3.4.

On Macs you should install the pommed package to make full use of the media keys on mac keyboards: brightness for display, keyboard, eject CD, play music.

Editing /etc/pommed.conf seems to have no effect on my keyboard backlight settings on startup. I have edited it to have the keyboard backlight to be off by default, but it comes on every time I log in or restart.

All settings respond fine to keyboard presses, though. Below is the contents of my /etc/pommed.conf:

#
# Configuration file for pommed
#

# General configuration
general {
    # fnmode: functions keys first (no need to use fn) or last
# Value is either 1 or 2, effect is hardware-dependent
fnmode = 1
}

# sysfs backlight control
# nVidia machines, will fall back to nv8600gmt if not supported by the kernel
lcd_sysfs {
# The sysfs backlight control is a generic interface provided
# by the Linux kernel for backlight control on most graphic cards.
# The brightness range can differ depending on the hardware.

# initial backlight level [12] (0 - 15, -1 to disable)
init = -1
# step value (1 - 2)
step = 1
# backlight level when on battery [6] (1 - 15, 0 to disable)
on_batt = 6
}

# ATI X1600 backlight control (MacBook Pro v1 & v2)
lcd_x1600 {
# initial backlight level [200] (0 - 255, -1 to disable)
init = -1
# step value (1 - 127)
step = 10
# backlight level when on battery [80] (1 - 255, 0 to disable)
on_batt = 80
}

# Intel 945GM, 965GM backlight control (MacBook v1-v4, MacBook Air v1)
lcd_gma950 {
# initial backlight level [0x6f] (0x1f - 0x94 usually, -1 to disable)
init = -1
# step value (0x01 - 0x20)
step = 0x0f
# backlight level when on battery [0x40] (0x1f - 0x94 usually, 0 to disable)
on_batt = 0x40
}

# nVidia GeForce 8600M GT/9400M/9600M GT backlight control
# (MacBook Pro v3-v5, MacBook v5, MacBook v2)
lcd_nv8600mgt {
# initial backlight level [12] (0 - 15, -1 to disable)
init = -1
# step value (1 - 2)
step = 1
# backlight level when on battery [6] (1 - 15, 0 to disable)
on_batt = 6
}

# Audio support
audio {
# disable audio support entirely
disabled = no

# Use amixer or alsamixer/alsamixergui to determine the sound card
# and the mixer elements to use here.

# sound card to use
card = "default"
# initial volume [80] (0 - 100%, -1 to disable)
init = -1
# step value (1 - 50%)
step = 5
# beep on volume change
beep = no
# mixer element for volume adjustment
volume = "PCM"
# mixer element for muting the speakers
speakers = "Front"
# mixer element for muting the headphones
headphones = "Headphone"
}

# Keyboard backlight control
kbd {
# default value for automatic backlight (0 - 255)
default = 0
# step value (1 - 127)
step = 10
# ambient light thresholds for automatic backlight (0 - 255)
on_threshold = 20
off_threshold = 40
# enable/disable automatic backlight
auto = no
# idle timer - fades keyboard backlight automatically (timeout in seconds, -1 to        disable)
idle_timer = 60
# idle level - level to fade keyboard to after idle_timer seconds. Defaults to     switching off.
# idle_level = 20
}

# CD/DVD drive ejection
eject {
# enable/disable eject key
enabled = yes
# CD/DVD device
device = "/dev/dvd"
}

# Beeper
beep {
# enable/disable beeper
# automatically disabled if audio support disabled above
enabled = no
# WAV file to use (from pommed: goutte.wav or click.wav in /usr/share/pommed)
beepfile = "/usr/share/pommed/goutte.wav"
}

# Apple Remote - deprecated
# Note: the appleir driver is required for this to work; this driver has been
# obsoleted with Linux 2.6.22, so unless you are running a kernel < 2.6.22 or
# use the appleir driver on a newer kernel, this won't work.
# You should use LIRC instead.
appleir {
# enable/disable the appleir support
enabled = no
}
share|improve this question
    
Same problem here! Have you made any progress by now? You might also want to take a look at this question askubuntu.com/q/135486/24668. –  user24668 May 12 '12 at 9:16
    
@gentmatt Thanks. I haven't made any progress. Those commands work but I can't get them to execute at login for some reason. –  Trey May 12 '12 at 17:24
    
I got a solution for 1/2 of the problem. You can add xbacklight -set 50 to your login items. This will ajust the display brightness to 50% of the maximum. (first install sudo apt-get install xbacklight) –  user24668 May 12 '12 at 17:27

2 Answers 2

Do you have a config file set somewhere to make pommed start on startup as root? And it does need root priviledges, according to my experience, or else it does nothing.

Also, to get the eject button to work, I made a keybinding to have the pressing of the eject button (XF86Eject on my Macbook 7,1 (white plastic, rounded edges)) execute the command "eject". Wasn't working via pommed.

share|improve this answer

Yep. Added "pommed" to the end of /etc/rc.local . Works for me now (upon startup). Notice everything in that script gets ran as root, so no "sudo" is needed.

Don't forget to set a keybinding between your eject button (for optical discs) and the eject command, unless somehow you got pommed to handle ejecting. If you don't have the eject command (go to terminal and type "eject", does it make the optical drive eject?), I'm sure you can install it from your package manager (apt-get if Ubuntu).

Cheers, Jake

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.