Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04.

When I plug My USB Mobile Broadband Modem, it is detected as a storage disk. It does not switch its mode to Modem. The modem is Micromax MMX310G 3G.

share|improve this question
    
Which is your modem? –  Tachyons May 3 '12 at 2:27
    
It is a Micromax MMx310G. –  shmzkm May 3 '12 at 8:56
1  
i also have a micromaxmmx353g. it does not run in ubuntu 2.04,thogh it runs well on previous version. i think the problem is with the kernel. and ubunutu 12.04 doesnt run sakis 3g also. –  user64189 May 17 '12 at 15:55
    
@shmzkm: If someone's answer was helpful to you, then please consider marking it as the accepted answer so others may more easily find it in the future. This is also a polite way to thank the person answering your question for helping you out. –  Danatela Mar 28 at 8:19

4 Answers 4

Have you perhaps had a look at this guide?

How to run micromax MMX 310G in ubuntu

There is also another guide on the Ubuntu Forums here:

Here

Let us know how you get on.

share|improve this answer
    
Thank you Sir very Much.to (andybleaden) –  shmzkm May 4 '12 at 8:50
    
@shmzkm, You could express gratitude by upvoting an answer that helped you. –  saji89 Jan 1 '13 at 6:16

This is the problem of your mobile settings
your mobile is in mas storage mode .change change in to PC suite mode

  • Change your mobile phone settings
  • active data cable for PC suite or contact your costumer care of your SIM card servicer
share|improve this answer
    
It is not mobile but mobile broadband by usb modem. –  beeju May 3 '12 at 9:13
1  
Sir Beeju.You are absolutely Right.It is a mobile broadband Modem.It was detected in 11.04 and 11.10.But it wont be detected in 12.04.I think it is a bug. –  shmzkm May 4 '12 at 8:46
    
I at last got the answer.Use sakis3g script(www.sakis3g.org).It worked perfectly –  shmzkm May 4 '12 at 8:58
    
@shmzkm, Please post that as an answer and mark that as accepted answer. –  saji89 Jan 1 '13 at 6:15

Open up a terminal from Applications -> Accessories. Type:

gksu gedit /etc/modules

At the bottom of the file, make two new lines, like this:

usbserial
option

Then close the editor program and save it. Reboot the computer and hopefully you’ll be right from now on!

share|improve this answer
  1. Download sakis3g script from following site http://www.snowguide.gr/gnu-linux-corner/raspberry-pi-raspbian/117-sakis3g-script
  2. save it in home folder and extract it.
  3. go to properties and in permission check allow it as executable.
  4. open terminal and type chmod a+x ./sakis3g and enter .
  5. now just type ./sakis3g and enter .
  6. a sakis3g window will open .
  7. just go through it what you think you should enter.
  8. Choose APN for your particular connection.(www for vodafone for example.)
  9. You can see that the modem is being detected.
  10. when you will be asked to enter user name just cancel it.It will show to be failed but don't worry.It will not cause anything.
  11. now you will see that there is an option for mobile broadband connection.click on it and it will be connected.

You are done.

Few things: When you starting your computer and connecting modem for the first time after starting computer you have to go through 5 to 12 .But after that if you disconnect your modem and connect it again it will automatically show your modem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.