Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Using Compiz by default in Unity 2D

When I try to run compiz on Unity 2D I can't use de Dash, and all my workspaces reduces to one single workspace. I want to know how to enable compiz effects on Unity 2D without thouse problems.

Thanks for any help.

share|improve this question
add comment

marked as duplicate by Javier Rivera, Jorge Castro, jokerdino, fossfreedom May 4 '12 at 9:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

This happens because 2D is using Metacity. Simple fix though...

Open Unity 2D's session settings:

gksudo gedit /usr/share/gnome-session/sessions/ubuntu-2d.session

Change metacity

[GNOME Session]
Name=Ubuntu 2D
RequiredComponents=gnome-settings-daemon;
RequiredProviders=windowmanager;panel;launcher;
DefaultProvider-windowmanager=metacity
DefaultProvider-panel=unity-2d-panel
DefaultProvider-launcher=unity-2d-launcher

DesktopName=Unity

To compiz

[GNOME Session]
Name=Ubuntu 2D
RequiredComponents=gnome-settings-daemon;
RequiredProviders=windowmanager;panel;launcher;
DefaultProvider-windowmanager=compiz
DefaultProvider-panel=unity-2d-panel
DefaultProvider-launcher=unity-2d-launcher

DesktopName=Unity

Save file and exit gedit

While still in terminal:

sudo restart lightdm

Log back in and have fun. Hope this helps :)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.