Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 10.04 yesterday on Lenovo G460. I'm unable to fix this problem after lot of tries in changing model in /etc/modprobe.d/alsa-base.conf to thinkpad/auto/lenovo and many things.

Can anyone please help me out with this?

share|improve this question
add comment

3 Answers 3

I had the same issue. It appears that the new kernel did not correctly detect the sound card model that you have. You will have to edit the /etc/modprobe.d/alsa-base.conf file and set the model manually with

options snd-hda-intel model=<model>

Unfortunately, finding the correct sound card model can take a little guess work. I took me several tries to find the sound card model that would detect the headphones correctly.

This link gives a list of sound card model: http://ubuntuforums.org/showthread.php?t=1043568

More information can be found on the Ubuntu Wiki: https://help.ubuntu.com/community/HdaIntelSoundHowto

share|improve this answer
add comment

I have something like this going on with my Sony VPCZ114GX, there is a workaround posted for my model at this bug report: https://bugs.launchpad.net/bugs/960124 Basically involves loading up David Henninsson's hda-jack-retask from his ppa at https://launchpad.net/~diwic/+archive/hda and then try Wouter van der Graaf's workaround on comment #7.

As for getting the model of your sound card, I tried the below. Although the problem may be that your machine doesn't know what model to use for sound in the first place.

$ aplay -l
** List of PLAYBACK Hardware Devices **
card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog] ...

Then to get the model to put in alsa-base.conf: $ gunzip -c /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz |grep -i "alc889"
intel-alc889a Intel IbexPeak with ALC889A
intel-x58 Intel DX58 with ALC889

share|improve this answer
add comment

I had the same problem after upgraging to 12.04 on my Acer Extensa machine. Changing options of the snd-hda-intel module had no effect. After spending few hours by googling with no success I tried to look at the settings in alsamixer. And found that only one thing I had to do was enabling muting speakers at this Alsa mixer frontend.

So my solution was to launch alsamixer in console window and by using keyboard to enable this option. How easy....

Hope that help.

Updade: the exact name of the option is "Auto-Mute Mode"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.