Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Broadcom BCM2046, it appears as connected in the bluetooth widget over the panel, and the hcitools drops me data, but it doesn't work at all, I've tried to connect from another device and it's inexistent and viceversa from PC to the device

hcitool dev and lsusb

hci0:   Type: BR/EDR  Bus: USB
BD Address: 89:21:09:79:B5:1B  ACL MTU: 1017:8  SCO MTU: 64:0
UP RUNNING PSCAN ISCAN 
RX bytes:779 acl:0 sco:0 events:27 errors:0
TX bytes:376 acl:0 sco:0 commands:27 errors:0

Bus 001 Device 007: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of       BCM2046 Bluetooth)
Bus 001 Device 008: ID 0a5c:2100 Broadcom Corp. Bluetooth 2.0+eDR dongle
share|improve this question

2 Answers 2

up vote 6 down vote accepted

Open up a terminal from Applications -> Accessories. Type:

sudo gedit /etc/modules

At the bottom of the file, make two new lines, like this:

usbserial
option

Then close the editor program and save it. Reboot the computer and hopefully you’ll be right from now on!

share|improve this answer

This worked for me

sudo hciconfig hci0 reset

Source : http://askubuntu.com/a/204427/69743

Running Gnome-Ubuntu 13.10

share|improve this answer
1  
Works on Kubuntu 14.04 –  Manck Aug 8 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.