Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to upgrade from 11.10 to 12.04.

I was making the upgrade over the X session of 11.10 i386. I was in the middle of the instalation when the X freezed. So i've made a reboot. When it restarted, i was already in 12.04 version but with the black screen problem. So i've added nomodeset to grub options.

I've runned the commands: sudo apt-get upgrade sudo apt-get dist-upgrade in order to install the missing packages (because of the X freeze). In total the commands installed/upgraded about 1GB more.

But no X yet. So i've uninstalled the fglrx packages and tried to install the amd ati (vendor) package. It give some errors (compilation errors) so i've cleaned it up and reinstalled the fglrx and fglrx-amdcccle ubuntu packages.

CURRENT PROBLEM: No X, yet.

When i run the command:

apt-get install fglrx fglrx-amdcccle

a strange output happens (related to link group i386-linux-gnu_gl_conf):

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  fglrx fglrx-amdcccle
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/45.1 MB of archives.
After this operation, 129 MB of additional disk space will be used.
Selecting previously unselected package fglrx.
(Reading database ... 
(Reading database ... 5%
[...]
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 483649 files and directories currently installed.)
Unpacking fglrx (from .../fglrx_2%3a8.960-0ubuntu1_i386.deb) ...
Selecting previously unselected package fglrx-amdcccle.
Unpacking fglrx-amdcccle (from .../fglrx-amdcccle_2%3a8.960-0ubuntu1_i386.deb) ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up fglrx (2:8.960-0ubuntu1) ...
update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode.
update-alternatives: warning: skip creation of /etc/OpenCL/vendors/amdocl64.icd because associated file /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (of link group i386-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/lib32/libaticalcl.so because associated file /usr/lib32/fglrx/libaticalcl.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/lib32/libaticalrt.so because associated file /usr/lib32/fglrx/libaticalrt.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group i386-linux-gnu_gl_conf is broken.
update-alternatives: warning: skip creation of /etc/OpenCL/vendors/amdocl64.icd because associated file /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (of link group i386-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/lib32/libaticalcl.so because associated file /usr/lib32/fglrx/libaticalcl.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/lib32/libaticalrt.so because associated file /usr/lib32/fglrx/libaticalrt.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
update-alternatives: using /usr/lib/fglrx/alt_ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
update-initramfs: deferring update (trigger activated)
Loading new fglrx-8.960 DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-24-generic-pae
Building for architecture i686
Building initial module for 3.2.0-24-generic-pae
Done.

fglrx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-24-generic-pae/updates/dkms/

depmod.......

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Setting up fglrx-amdcccle (2:8.960-0ubuntu1) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-24-generic-pae
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

But it seems to install correctly and compiled all the modules to the current kernel.

runned the commmand: aticonfig --initial -f

After reboot, still no X .

I tried to run the X with no fglrx drivers and with. I spend a lot of time on this problem and i really wonder if i can solve it widthout reinstalling ubuntu from scratch.

Other info:

uname -a

Linux  [name] 3.2.0-24.generic-pae #37-ubuntu  SMP Wed Apr 25 10:47:59 UTC 2012 i686 i686 i368

lspci

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series]

Xorg.0.log

[    24.741] 
X.Org X Server 1.11.3
Release Date: 2011-12-16
[    24.741] X Protocol Version 11, Revision 0
[    24.741] Build Operating System: Linux 2.6.42-23-generic i686 Ubuntu
[    24.741] Current Operating System: Linux beatsaudio 3.2.0-24-generic-pae #37-Ubuntu SMP Wed Apr 25 10:47:59 UTC 2012 i686
[    24.741] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic-pae root=UUID=dab0cc0d-adaa-4a14-a633-b2f9841935ff ro quiet splash nomodeset vt.handoff=7
[    24.741] Build Date: 20 April 2012  05:12:21AM

[.....]

[    28.283] 0: /usr/bin/X (xorg_backtrace+0x37) [0xb7724627]
[    28.283] 1: /usr/bin/X (0xb759c000+0x18c3aa) [0xb77283aa]
[    28.283] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb757940c]
[    28.283] 3: /lib/i386-linux-gnu/libc.so.6 (0xb71d9000+0x135d32) [0xb730ed32]
[    28.283] 4: /usr/bin/X (XIChangeDeviceProperty+0x16c) [0xb76bcafc]
[    28.283] 5: /usr/lib/xorg/modules/input/evdev_drv.so (0xb4a25000+0x634e) [0xb4a2b34e]
[    28.283] 6: /usr/lib/xorg/modules/input/evdev_drv.so (0xb4a25000+0x6595) [0xb4a2b595]
[    28.283] 7: /usr/bin/X (ActivateDevice+0x66) [0xb75c82e6]
[    28.284] 8: /usr/bin/X (0xb759c000+0x8cc05) [0xb7628c05]
[    28.284] 9: /usr/bin/X (0xb759c000+0x9b142) [0xb7637142]
[    28.284] 10: /usr/bin/X (0xb759c000+0x9b9b3) [0xb76379b3]
[    28.284] 11: /usr/bin/X (config_init+0x14) [0xb7636a14]
[    28.284] 12: /usr/bin/X (InitInput+0xfd) [0xb7616edd]
[    28.284] 13: /usr/bin/X (0xb759c000+0x2524e) [0xb75c124e]
[    28.284] 14: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0xb71f24d3]
[    28.284] 15: /usr/bin/X (0xb759c000+0x255e9) [0xb75c15e9]
[    28.284] Segmentation fault at address 0xf3
[    28.284] 
Caught signal 11 (Segmentation fault). Server aborting
[    28.284] 
Please consult the The X.Org Foundation support 
     at 
 for help. 
[    28.284] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    28.284] 
[    28.288] (II) evdev: Power Button: Close
[    28.288] (II) UnloadModule: "evdev"
[    28.288] (II) Unloading evdev
[    28.292] (II) evdev: Video Bus: Close
[    28.292] (II) UnloadModule: "evdev"
[    28.292] (II) Unloading evdev
[    28.308] (II) evdev: Video Bus: Close
[    28.308] (II) UnloadModule: "evdev"
[    28.308] (II) Unloading evdev
[    28.312] (II) evdev: Power Button: Close
[    28.312] (II) UnloadModule: "evdev"
[    28.312] (II) Unloading evdev
[    28.312] (II) UnloadModule: "evdev"
[    28.312] (II) Unloading evdev
[    28.664]  ddxSigGiveUp: Closing log
[    28.664] Server terminated with error (1). Closing log file.

Can you please help?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Ok. I found out the problem. Follow this link: http://ubuntuforums.org/showthread.php?t=1969827

share|improve this answer
    
I had to reinstall X first... –  Eduardo Pinheiro May 4 '12 at 11:48
add comment

Ok. I just uninstalled apt-get remove --purge xorg* and installed apt-get install ubuntu-desktop and i have X with a very low resolution.

I installed (the community version of fglrx, the amd version) and no luck for getting the graphics work with fglrx.

The Xorg.0.log file now says:

xf860OpenConsole: setpgid Failed: Operation not permitted
xf860OpenConsole: setsid Failed: Operation not permitted
Faaling back to old probe method for fglrx
Loading PCS database from /etc/ati/amdpcsdb
No devices detected
Fatal server error:
 no screens found

I have X but in low graphic mode......

My Graphic card is: AMD HD 6630M and it was working fine in 11.10 ubuntu with these drivers.

Please help.

Thanks in advance.

share|improve this answer
    
My xorg is still the same.... (i runned the aticonfig --initial -f) i've uninstalled and installed different versions many times too... –  Eduardo Pinheiro May 3 '12 at 11:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.