Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated recently to 12.04. At first, everything worked perfectly. But since today, I get stuck at the login screen. Whenever I enter my password, it says "logging in" but won't continue from there. I don't see anything alarming @dmesg.

Thanks already in advance.

edit: in /var/log/lightdm/x-0-greeter.log I see some critical errors:

CRITICAL: ido_calendar_menu_item_set_date: assertion 'IDO_IS_CALENDAR_MENU_ITEM(menuitem)' failed

... [some debug messages about permission denied to load background]

CRITICAL: background_loader_create_pattern: assertion 'image != NULL' failed

edit2: just compared it to a previous, successful login. The only difference I see is this line:

DEBUG: unity-greter.vala:496: Failed to write state: Error writing to file: Bad address
share|improve this question
1  
At the login screen, press Ctrl+Alt+F1 and log in. Then have a look at the LightDM logs, located at /var/log/lightdm/x-0-greeter.log and /var/log/lightdm/lightdm.log –  Shah May 2 '12 at 21:42
    
is that enough or do you need the full logs? –  panmari May 2 '12 at 21:51
    
you can install other launchers like kdm or gnome. That may resolve your problem –  ashutosh May 2 '12 at 21:53
    
I do have gnome installed. But both, unity and gnome, don't work. –  panmari May 2 '12 at 21:54
    
check this out if it can help –  ashutosh May 2 '12 at 21:56
show 3 more comments

closed as off topic by fossfreedom May 22 '12 at 18:37

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

up vote 5 down vote accepted

I can't tell exactly what's wrong from your log messages, but in order to login, you can do the following (as a workaround).

  1. Press Ctrl + Alt + F1
  2. Login
  3. Install GDM:

    sudo apt-get install gdm

  4. Make GDM the default:

    sudo dpkg-reconfigure gdm

  5. Reboot your machine

  6. You will now see the old style login screen, and you should be able to log in.

Edit: The "[some debug messages about permission denied to load background]" may be telling. Are you using a custom wallpaper? If yes - once you have logged in using GDM, go to your desktop, right click and choose one of the default Ubuntu wallpapers. Try making LightDM your default again.

sudo dpkg-reconfigure gdm

And reboot. If you are then able to log in using LightDM, your custom wallpaper location was the culprit. Else, follow the steps above to once again use GDM.

share|improve this answer
    
k, I'll try that –  panmari May 2 '12 at 22:23
    
I edited at the same time as you commented - please note the additional info about custom/default wallpapers. –  Shah May 2 '12 at 22:27
    
I don't think this is the source of the error, bc these debug messages also showed up also in previous, succesful logins. –  panmari May 2 '12 at 22:33
    
...nevertheless, you were right! Your suggested method works perfectly fine, thanks a lot! –  panmari May 2 '12 at 22:38
add comment

The proposed solution at Cannot login to my user account helped me.

rm ~/.Xauthority

For completeness: I had this problem, changed to gdm. Then removed the file, then changed back to lightdm with

sudo dpkg-reconfigure lightdm
share|improve this answer
    
Thank you, this worked for me –  Siya Nov 14 '13 at 13:48
add comment

I have a feeling you are encountering the same issue as I.

Let's see what we have, on the surface it appears to either be an issue with lightdm itself or with our graphics driver (at least for me, my resolution reduced to 640x480) - lets take a look at the logs!

First looking to lightdm's logs

sudo nano /var/log/lightdm/x-0.log

or alternatively we can look through the Xorg file for errors, coded (EE) within the file

grep -e '(EE)' /var/log/Xorg.0.log

in both instances we are greeted with the same two errors (if not, perhaps we have differing issues)

[...](EE) No devices detected.
[...](EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Lets get Xorg back into shape and working for us. First lets backup the current Xorg by renaming the file xorg.conf.backup...

sudo mv  /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Now we can reinstall Mesa for GL

sudo apt-get --reinstall install libgl1-mesa-glx

Reboot your computer

sudo reboot

After the reboot, your computer should be back to a functioning state albeit absent hardware acceleration. I have found that the NVIDIA drivers that come with 12.04 are highly inadequate, I suggest utilizing this PPA for NVIDIA driver needs (Sorry AMD/ATI peoples, not sure what to do for you)

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

The above PPA is to support all graphics cards, not just NVIDIA.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.