Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi ask ubuntu my wireless is not working so here is my info : System Using : Lenovo Z570

$ iwconfig

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.

$ sudo ifconfig

eth0      Link encap:Ethernet  HWaddr f0:de:f1:54:34:a2  
          inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::f2de:f1ff:fe54:34a2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:44257 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40079 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:43571495 (43.5 MB)  TX bytes:4926319 (4.9 MB)
          Interrupt:42 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5977 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5977 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:708983 (708.9 KB)  TX bytes:708983 (708.9 KB)

wlan0 is not showing in thils , but now when i try to use.

$ sudo ifconfig wlan0 up

SIOCSIFFLAGS: Operation not possible due to RF-kill

Now when i use this :

$ sudo rfkill list all

1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
2: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Then i use command:

$ sudo rfkill unblock all

Then :

$ sudo rfkill list all

1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
2: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Here phy0 Hard blocked = yes

Result was the same (then i again try to switch on/off wifi from keyboard by pressing Fn+F5 )

$ sudo rfkill list all

1: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
2: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Now this time phy0 Soft blocked = yes as well as hard blocked : yes

Here is hardwares specs :

$ sudo lshw -class network

*-network DISABLED      
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 01
       serial: 68:a3:c4:9a:7e:62
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.2.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f1900000-f190ffff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 05
       serial: f0:de:f1:54:34:a2
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8105e-1.fw ip=192.168.2.2 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:42 ioport:2000(size=256) memory:f1804000-f1804fff memory:f1800000-f1803fff
share|improve this question
    
BIOS resert had helped me like here askubuntu.com/questions/75969/… –  user64760 May 19 '12 at 22:05

2 Answers 2

I had this same problem. I solved it by pressing Fn+F2 on my keyboard. Press Fn and the key with the wifi symbol. It set the hard block to 'no'

share|improve this answer

I had the same problem with a Lenovo IdeaPad N585 (same Atheros card) where the hard blocked could only be controlled by the Energy Management software from Windows. Once it is enabled in Windows, it seems to stick throughout reboots so I had to enable it only once in Windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.