Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.04 with a second screen. The laptop screen is where I do most of the work and the second screen is mostly for displaying documentation and things like that. That's why it's very annoying when dialogs appear on the external screen even though the program that triggered the dialog is displayed on the laptop screen.

Is it possible to fix this annoying behaviour? Ideally dialogs should be displayed on the same screen as their parent window, but an acceptable workaround would be to declare my laptop screen as the "primary" screen and show all new dialogs there.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

You can set it with xrandr. The command is: xrandr --output <your output> --primary

To get what you will put at <your output> you can run just xrandr to show your options. See this example:

~$ xrandr
Screen 0: minimum 320 x 200, current 2880 x 1200, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 261mm x 163mm
   1280x800       60.0*+
   1024x768       60.0
   800x600        60.3     56.2
   640x480        59.9
HDMI1 connected 1600x1200+1280+0 (normal left inverted right x axis y axis) 367mm x 275mm
   1600x1200      60.0*+
   1280x1024      75.0     60.0
   1152x864       75.0
   1024x768       75.1     60.0
   800x600        75.0     60.3
   640x480        75.0     60.0
   720x400        70.1
DP1 disconnected (normal left inverted right x axis y axis)  

He sets the HDMI1 as primary with this command: xrandr --output HDMI1 --primary

Reference: 1.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.