Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Ubuntu 12.04 with Unity 2D, it appears as though you can set the default program for any file (type) by right-clicking the file -> Properties -> Open With -> Set as default. However the "Set as default" button (and the neighboring "Add" button) are grayed out.

How can I "ungray" these two button so as to use them?

I would expect there to be an "Unlock" button that prompts for my password as there is on the All Settings -> User Accounts window, but this is not the case.

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

They are grayed out because the default program is selected.

enter image description here

Just click on any other program and the buttons will be clickable again.

enter image description here

share|improve this answer
    
Thanks for this answer. How stupid is it that this capability can be found in the file properties dialog, but not the "open with..." dialog! –  HDave May 3 '12 at 15:51
    
So you can't set a custom command anymore ? or did I missed something ? –  user55822 May 3 '12 at 16:27
    
@Hdave You can do the same in "Open with" dialog. –  Basharat Sial May 3 '12 at 16:32
    
On my 12.04, the open with dialog has not "set as default" button. –  HDave May 4 '12 at 2:00
1  
I was hoping that "Add" would allow me to add an application not is not in either the "Default" or "Other Applications" lists since the program that I want to use it not listed. Does anyone know how to do that? –  Tyson Williams May 4 '12 at 17:04
show 4 more comments

How to set the default application for a particular file type in 12.04.

Using the file manager (Nautilus) navigate to a file of the required type. Right click it and select "Properties". Then go to the "Open with" tab and make your selection.

Note that this DOESN'T WORK if you follow a slightly different sequence. If you select "Open with other application" directly from the right click menu, then the button to make it default is not displayed.

This is the "crazy" situation that HDave refers to in the comments. It took me a while to discover how to get round it.

share|improve this answer
    
This does not solve the problem because there are still options missing from that list of applications, namely Kile with working with a .tex file, and no way to select another application. –  Tyson Williams May 23 '12 at 14:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.