Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is the third time that I've downloaded and installed Ubuntu 12.04 amd64 on my x120e successfully (using 3 different well formatted USB sticks) BUT when I reboot after installation, I get an error saying Operating System Not found.

I have no clue what to do. I simply wish it booted normally.

Big thanks in advance.

share|improve this question

I just solved the exact same issue, hopefully this will help you. Worked on my x120e.

In the bios, set it to boot EFI mode only (the default is "Both" and the other option is bios only). Then, boot off the USB stick. You should see a grub menu when you start booting off the stick, and not a "syslinux" or unetbootin-style one.

Once you are in the Ubuntu installer, create your partitions as you would normally, but add an additional 512 Mb partition. Set it's type to "EFI Boot" (as opposed to Ext4 or swap types). Continues the installation as you would normally, and once it's done it should reboot into Ubuntu just fine.

share|improve this answer
Sorry mate that does not work either... the same result repeats : "Operating System not found" – technoSesh Jun 20 '12 at 8:04

I solved the problem by changing the bios option to "legacy only" and then did a reinstall of Ubuntu.
My partitions are:

  • /boot
  • / (for Ubuntu)
  • swap
  • .

I left the NTFS recovery partition intact.

share|improve this answer
What is the fourth partition for? – saji89 Oct 22 '12 at 8:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.