Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problems on updating Ubuntu 11.10 to 12.04, I've tried to update all possible ways.

I'v downloaded Ubuntu 12.04 from cd...but when booting the upgrade option wont appear...just: Install alongside-Erase disk and Install-Other.

So after waiting 5 days I thought that be enough to update the mirror for my contry, Spain. Even though is not showing any upgrade to 12.04 just normal updates...I've tried changing the mirrors and changed to main server and luck either...after googling a bit..I've found this mirror which does host an upgrade to 12.04 and switched to that mirror with no luck on upgrade either. ftp.halifax.rwth-aachen.de

Read here and there and tried Sudo apt-get update Sudo apt-get dist-upgrade and do-release-upgrade

No luck with all of them....in doing do release upgrade I get:

Checking for a new ubuntu release
Unhandled exception in thread started by <bound method MetaReleaseCore.download of <UpdateManager.Core.MetaRelease.MetaReleaseCore object at 0x7f03a9f09fd0>>
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/UpdateManager/Core/MetaRelease.py", line 261, in download
uri=urllib2.urlopen(req, timeout=20)
File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
return _opener.open(url, data, timeout)
File "/usr/lib/python2.7/urllib2.py", line 394, in open
response = self._open(req, data)
File "/usr/lib/python2.7/urllib2.py", line 412, in _open
'_open', req)
File "/usr/lib/python2.7/urllib2.py", line 372, in _call_chain
result = func(*args)
File "/usr/lib/python2.7/urllib2.py", line 1201, in http_open
return self.do_open(httplib.HTTPConnection, req)
File "/usr/lib/python2.7/urllib2.py", line 1174, in do_open
r = h.getresponse(buffering=True)
File "/usr/lib/python2.7/httplib.py", line 1027, in getresponse
response.begin()
File "/usr/lib/python2.7/httplib.py", line 407, in begin
version, status, reason = self._read_status()
File "/usr/lib/python2.7/httplib.py", line 365, in _read_status
line = self.fp.readline()
File "/usr/lib/python2.7/socket.py", line 447, in readline
data = self._sock.recv(self._rbufsize)
socket.timeout: timed out
^CTraceback (most recent call last):
File "/usr/bin/do-release-upgrade", line 83, in <module>
time.sleep(0.5)
KeyboardInterrupt

After doing what jhon suggested I got no network working with ethernet or wireless either.

Any ideas??I think netroot is what crashed the networking..?

share|improve this question
    
Welcome to Ask Ubuntu! This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro May 2 '12 at 20:26
1  
Wait, did you hit Ctrl-C in the terminal while doing this? –  Jjed May 2 '12 at 21:16
    
@JacobJohanEdwards Yes I did Ctrl-c after waiting 10 min, but i did that after getting this: "messege socket.timeout: timed out" then i got as messege: ^CTraceback (most recent call last): File "/usr/bin/do-release-upgrade", line 83, in <module> time.sleep(0.5) KeyboardInterrupt –  kiraitachi May 3 '12 at 7:40

3 Answers 3

up vote 0 down vote accepted

Have you tried booting with RecoveryMode and then attempting to repair you packages? Here's what I think I would do.

  1. Boot to your GRUB boot menu.
    Note: If the GRUB menu does not appear when you boot, hold down the Shift key immediately after the BIOS finishes loading and booting begins. The GRUB menu should appear. If instead you see the Ubuntu logo, then you've gone too far. Try again.
  2. The Grub menu should look something like this:
        Ubuntu, with Linux 3.2.0-23-generic
        Ubuntu, with Linux 3.2.0-23-generic (recovery mode)
        Memory test (memtest86+)
        Memory test (memtest86+, serial console 115200)
    

    Select the (recovery mode) GRUB menu item and press enter.

  3. You should eventually see the RecoveryMode menu (image below).

    Ubuntu RecoveryMode menu

Now perform the following steps ...

  1. Select & run the fsck entry in the Recovery Menu.
    When you boot into RecoveryMode the filesystem in your root (/) partition is mounted as read-only as a safety measure. If fsck completes successfully, your install partition will be remounted as read/write allowing you to make changes.
  2. Select & run the network menu entry.
    This should enable you to access the Internet and download updates during the next step.
  3. Select & run the dpkg menu entry.
    This will examine the software packages on your system. If a problem is found, it will attempt to repair them if it can.
  4. When the processing for dpkg has completed you can resume booting. However, you may need to reboot for your graphics drivers to be properly initialized.
share|improve this answer
    
Nothing no luck either @irrationalJohn...with that answer...just getting things worse...after doing netroot with the recovery console now my connections on ethernet or wireless wont work...:/ –  kiraitachi May 3 '12 at 7:58
    
If I understand you correctly step (2) failed? Did you try step (3)? Does your network still not work even after a normal boot? Have you done anything to try to fix it? –  irrational John May 3 '12 at 13:02
    
From your comment @JacobJohanEdwards it sounds like your lost network access back when you did the ctrl+c and got the stack traceback. –  irrational John May 3 '12 at 13:11
    
no, I lost network after I did the recovery mode....anyway I did a fresh Install..:/ –  kiraitachi May 3 '12 at 19:46
    
The message socket.timeout: timed out in your comment @JacobJohanEdwards implies a network problem. An application (the update routine?) was attempting to establish a connection across the network, but it timed out. I wonder what else might be in your logs? –  irrational John May 3 '12 at 19:52

Try on a terminal:

sudo update-manager -d
share|improve this answer
    
Worked for me. Thanks :) –  bludger May 11 '12 at 12:46

Yes, this error happens when you don't have a proper connection.

Errors like:
socket.timeout: timed out
socket.error: [Errno 104] Connection reset by peer

Probably your network was disconnected during the upgrade or some temporary server problem. Check if you are behind the firewall or re-try again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.