Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Most of the time when I log in, I after I enter my password, it says login in, and nothing else happens.

share|improve this question

closed as off topic by fossfreedom May 22 '12 at 18:38

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

The same thing has just started happening on my system too. Very frustrating! – Ian Dickinson May 2 '12 at 18:33
experiencing this as well – ilprincipe May 2 '12 at 21:57
Similar question? – fossfreedom May 3 '12 at 11:40
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. – fossfreedom May 22 '12 at 18:38
I don't understand why this is off-topic. It's a problem that multiple people, including me, have experienced and something that a desktop OS user would probably want solved. At a minimum the answers explaining that it is a bug are useful for someone who does a Google search about the problem and ends up here. – Gabriel Southern Jan 26 '13 at 20:56

I have the same problem and found out, that there is already a confirmed bug reported on launchpad for this problem:

I wrote a question for this problem on askubuntu myself with a bunch of log output ... LightDM hangs at login - Error MSG in auth.log - what can I do?

maybe it's an authentication problem, because when I can login, this line in auth.log is present:

polkitd(authority=local): Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.47 [/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale de_DE.UTF-8)

and when I have the problem, this line isn't there...

(I somehow can't comment so I wrote an answer... I hope that isn't rude or something)

edit: There is an unofficial bugfix posted in launchpad. I didn't try it yet.

Michael Terry (mterry) wrote 6 minutes ago:

Hello! I think I have a fix for this. See for the techy explanation of why this happens.

But if you want to test the fix or just are interested in fixing it soon, please try this ppa:

edit: People in Launchpad report that the bugfix is working, and that the problem may be caused by deactivating the login sound with Ubuntu Tweak. Maybe reactivating the login sound might fix this problem too until a official update is available

share|improve this answer

I experienced the same problem after several updates were installed this morning. To avoid more frustration, the solution I found was to install gdm and use it as my display manager.

sudo install gdm

It might not be the definitive solution.

share|improve this answer
By the way, this seems to be related to this issue, but in my case I didn't install Ubuntu Tweak. The problem pops up spontaneously after a series of automatic updates. – Boj May 3 '12 at 0:05

I noticed the same problem too, several times. When the login screen hangs up, I switch to command line (CTRL+ALT+F1) and simply stop and start LightDM again. Annoying problem, for the moment I think I'll try this way, until the problem is fixed.

sudo stop lightdm
sudo start lightdm
share|improve this answer
When I press Ctrl+Alt+F1, it asks for my password but it won't accept my password when I enter it. I tried it a few times to see if it was entered correctly. – NaturistGirl May 13 '12 at 8:08
@NaturistGirl numlock? – m93a Sep 24 '13 at 19:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.