Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed atftpd on Ubuntu 12.04, but it looks like I cannot start the tftp server, and there's a problem also with the tftpd daemon. With Ubuntu 11.10 there was no problem.

ureadahead will be reprofiled on next reboot
atftpd (0.7.dfsg-11) wird eingerichtet ...
unknown protocol: udp4

With rlinetd, and also as daemon, it doesn't work.
with ps -afe I see no process.

/var/log/syslog says it cannot bind to ip address.

with option --bind-adress the atftpd server starts but also doesn't work.

share|improve this question

4 Answers 4

I've checked out atftpd source code, and find out that working line for /etc/default/atftpd is

USE_INETD=false
OPTIONS="--tftpd-timeout 300 --retry-timeout 5 --port=69 --maxthread 100 --verbose=5 /srv/tftp"

You need to specify port to fool atftpd. So now tftp server is available from all network interfaces.

share|improve this answer
    
This was my problem, I realised I needed to change the true to false but it was the OPTIONS line that caught me out. Thanks! –  jwbensley Mar 4 at 17:07

You are probably affected by bug #993101

Please confirm if you are having same problem! Eventually, you can always download the source and install by yourself..

share|improve this answer

This is how I got atftpd working in 12.04:

  1. Edit /etc/default/atftpd

    a. Change inetd=true to inetd=false

    b. Removed all multicast options, added --bind-address=<my local static ip>

    c. Created /tftpboot directory (modify /etc/default/atftpd accordingly as the default directory is something else) with user nobody group nogroup

    d. Also added --logfile /var/log/atftpd.log (first touch /var/log/atftpd.log and set permissions accordingly)

    e. Set --verbose=7 to capture all messages

  2. Edit /etc/rlinetd.conf and made services available only local network by specifying my interface as my local IP address.

  3. Stopped started rlinetd

  4. Ran invoke-rc.d atftpd start as root.

Hope this is useful.

share|improve this answer
    
what is the point of step 2? –  Casey Jan 13 '13 at 6:14

Ubuntu 12.04 LTS

This system has an ip address of 192.168.0.5

sudo touch /var/log/atftpd.log

sudo chmod 644 /var/log/atftpd.log

here's my /etc/default/atftpd

USE_INETD=false
OPTIONS="--port=69 --tftpd-timeout 300 --retry-timeout 5 --mcast-port 1758 --mca
st-addr 192.168.0.0-255 --mcast-ttl 1 --maxthread 100 --verbose=7 /tftpboot --lo
gfile /var/log/atftpd.log"

sudo mkdir /tftpboot

sudo chmod 777 /tftpboot

touch /tftpboot/simple.txt

sudo invoke-rc.d atftpd restart

From another system (on the same subnet) running busybox

tftp -l simple.txt -g 192.168.0.5

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.