Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is probably going to sound like a rookie question, but I have never ever experienced such issue. I had Ubuntu 11.10 without Unity installed on my old laptop Thinkpad Z60m. Few days ago, I got notification that 12.04 LTS is outside and that I should upgrade. As it is my old laptop, with nothing important on, I decided to go for it. All fine and well. Except, now, Ubuntu behaves like I am not using a laptop. There is no battery indicator and I cannot enable it via Power settings (setting doesn't get stored). Also, power consumption is enormous, so it is now hardly usable running only on battery. Thing is 11.10 worked fine. Also, my battery held up to 3 hours.

So, I guess my question is, is there anything I can do to fix this, or do I need a reinstall?

share|improve this question

closed as too localized by Jorge Castro, Uri Herrera, RobotHumans, belacqua, RolandiXor Aug 22 '12 at 15:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

I would suggest reinstalling yes, but see if any of the experts come up with anything first. Well thats unless you can't wait to experience the brilliance of Ubuntu 12.04! – Ross Fleming May 2 '12 at 16:02
I am all ears :). Reinstall is my last solution. – Vlad May 2 '12 at 16:16
The missing battery indicator issue is discussed in This also happened to me when I upgraded to 11.10 and it seems this issue is back with 12.04. Good luck! – user62095 May 9 '12 at 18:04
See:… – david6 May 16 '12 at 9:13
Those links would be even better, if they actually contained a solution. :) – Vladimir Kocjancic May 20 '12 at 13:27

I don't know if this helps (maybe charger, battery problem). Found it on Youtube. Kind of old and it is Dell. Your charger is not recognized by your BIOS. And if your computer does not see an original charger the battery will not charge at all. Can sort this out by removing this idiotic option from the BIOS. They will give you another charger or change your motherboard (useless) and this problem will appear again after your warranty has expired.

Another reason why this is happening could be because you broke the prong on your charger, that's why its not charging. You must fix or replace the charger. It has nothing to do with the Laptop or battery. I had the same problem. I just added a new prong and it worked fine. It only took me about 5 minutes to fix. Easy fix if you know what you are doing.

share|improve this answer
Which part of "it worked prior upgrade" was not clear? – Vladimir Kocjancic Jun 14 '12 at 15:43

I always prefer a "clean install" of the operating system as compared to upgrading an existing one.

My reason is this "that if there’s a hidden problem when you upgrade the hidden problem shows up."

So perhaps reinstall a fresh copy of Ubuntu.

Dont forget to save your data first.

Hope this is of help but others may have other ideas .

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.