Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo Thinkpad T410 which used to run nice under 11.10. Yesterday I upgraded to 12.04 and from that point on I cannot login. My laptop boots normally and I am presented with the log in screen in which I type my password / or scan my fingerprint and it seems that it is accepted because the screen goes black. After that some output is show for a very brief time and I am again directed back to the log in screen. My password is correct because every time I use a wrong one it does not go to the black screen. I tried removing and reinstalling nvidia current drivers but nothing changes. I am able to enter into guest session but that is not helpful.

I tried the fsck option and the dpkg and failsafe graphics in the recovery mode but nothing helped. I tried all the apt-get clean, -f install, purge, autoremove and every other thing I could imagine. If anyone has an idea I am more than welcome to try.

Thank you

share|improve this question
    
Welcome to Ask Ubuntu! Congrats on getting it solved, can you add that as an answer? :) –  fossfreedom May 2 '12 at 18:20
add comment

3 Answers 3

I was able to pass the login screen. All I needed to do was to remove the .Xauthority file in my home directory and after that it logged in fine. Now tha only issue is that I am spammed with ubuntu errors that require me to send a report, but this is good and it will help resolve them.

share|improve this answer
1  
You should accept this answer, so it's clear to other people searching that this question has been solved and what the solution is. (You were unable to do so when you first posted it, because you have to wait 2 days between posting your own answer to your question and accepting it.) –  Eliah Kagan Jul 21 '12 at 6:05
add comment

LightDM may have "forgotten" your default session and may be trying to log you into an empty session. Try selecting the Unity session from the login screen (top right hand corner of the password box).

share|improve this answer
    
Hi thanks for the reply. I do not have the unity option you refer to I have the ubuntu, ubuntu 2d, lcewm, xbmc, icewm, gnome, gnome classic, and gnome classic (no effects). And none of them works –  thenoone May 2 '12 at 16:37
add comment

I had the same problem after upgrading to 12.04. I found that the upgrade reset my user and group ids. This made the login process unable to read the contents of my existing home directory. Logging in from console worked. From there I ran "sudo bash" and as root, updated /etc/passwd and /etc/groups with my original ids. I then had to chown my home directory back to myself. After that, the regular login worked. Hope that helps!

share|improve this answer
    
Hi and thanks for your help. I was able to resolve my problem in a different way –  thenoone May 2 '12 at 17:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.