Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on precise, unity works fine but I would like to improve the performances of the system. The dash, for example, is slow and has an high cpu usage. Compiz in general uses 3-4% of cpu, and this is quite annoying for a notebook. What can I do?

share|improve this question
add comment

2 Answers

Take the following steps for better performance:

  1. Open compizconfig-settings-manager. Go to OPENGL section. uncheck Sync To VBlank
  2. Add vm.swappiness=$VALUE in /etc/sysctl.conf file by executing

    echo "vm.swappiness=10" |sudo tee -a /etc/sysctl.conf > /dev/null
    
  3. Use swap. If you don't have, create using this tutorial.
  4. Again compiz-settings-manager. Go to Unity plugin > Experimental section. Change Dash bar to static blur
  5. Avoid left click on dash. Use right click for specific option.
  6. If you have a /etc/X11/xorg.conf file (do not create it if you do not have one), add the following lines in Device section

    Option "AccelMethod" "EXA"
    Option "MigrationHeuristic" "greedy"
    Option "AccelDFS" "true"
    Option "EnablePageFlip" "true"
    Option "EnableDepthMoves" "true"
    
share|improve this answer
    
Why code tag is not working :( ? –  shantanu Sep 14 '12 at 9:44
    
You need to indent it with an additional four spaces if you are using it in an enumeration. –  Lekensteyn Sep 14 '12 at 10:28
    
thanks @Lekensteyn –  shantanu Sep 14 '12 at 11:22
add comment

That is actually quite good for compiz on nvidia, as it can be much higher.

See this thread for more information on the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.