Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my Ubuntu 12.04, I have two monitors: left is the laptop and the right one is an external and big monitor. My vision is generally focused on the laptop monitor, but the notifications appears in the right one, therefore, I lose the notifications.

Is possible to change the location of the notifications? For example, the notifications appear on the top-right corner of the laptop/left monitor.

share|improve this question
    
Duplicate question, see possible answers in: askubuntu.com/questions/33140/notify-osd-and-dual-monitors –  user59621 May 2 '12 at 15:41
    
It is not the answer. Indeed, it is the opposite thing that I want. I want to show the notifications in my laptop and not on the external monitor. –  Paul Leger Morales May 2 '12 at 16:22

3 Answers 3

For an imperfect workaround, install dconf-editor (provided by the package dconf-tools), navigate to Apps > notify-osd and change the value of multihead mode to focus-follow.

This will draw the volume notifications a little too high up on your left monitor, causing them to overlap the panel - but they will at least be drawn on your left monitor. Email/message/music/other notifications don't overlap and look fine using this method.

share|improve this answer
    
It works, thank you very much. I am a happy man now :). –  Paul Leger Morales May 5 '12 at 21:59

It is currently not possible to change the location of the notifications. By the design they should appear in top-right corner of your primary screen, but because of this bug:

https://bugs.launchpad.net/ubuntu/+source/notify-osd/+bug/331369

they will always appear on your most right monitor.

There used to be a patch to notify-osd by Roman (Leolik) Sukochev that allowed user to change behaviour of notification, but it was not ported to 12.04 yet.

Right now you can only wait for bug to be fixed or for new version of Leolik's patch or you can set your laptop monitor to be on right side.

ALSO: it does not matter in this case if your monitor is 'laptop' or external, so your question is a duplicate of: notify-osd and dual monitors as stated by user59621.

share|improve this answer
    
I read about the patch of Leolik, but I think this patch is not the solution because this patch only allows a user to choose the location inside of one screen, and not allowing to choose the screen. –  Paul Leger Morales May 3 '12 at 13:20

Instructions for installing the patch mentioned above on 12.04 are available in this thread: How to customize on screen notifications? and there is a setting in it for positioning labeled "dynamic" which I found fixed this problem. However, I did not like the way it altered the color and styling of the notifications, so I undid those changes and then used the dconf solution mentioned in a comment in this thread, which I found works pretty well. The slight differences in positioning are a bit annoying though. Hopefully they can fix this soon, as it is quite frustrating.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.