Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to increase the size of a VirtualBox Win7 .vdi disk on Ubuntu 10.04 but when I try executing VBoxManage modifyhd /path/disk.vdi --resize 15360 it returns Syntax error: unknown option: --resize. I'm unsure as to why this is happening because I've used it before and it's still listed under valid options for VBoxManage modifyhd in the VirualBox User Manual .

Cheers, George

@maniat1k

george@george-laptop:~$ VBoxManage modifyhd '/home/george/.VirtualBox/HardDisks/Windows 7 64bit.vdi' --resize 15360
Sun VirtualBox Command Line Management Interface Version 3.1.6_OSE
(C) 2005-2010 Sun Microsystems, Inc.
All rights reserved.

Usage:

VBoxManage modifyhd         |
                            [--type normal|writethrough|immutable]
                            [--autoreset on|off]
                            [--compact]


Syntax error: unknown option: --resize
share|improve this question
    
VBoxManage modifyhd <filename> --resize <megabytes> –  maniat1k May 2 '12 at 14:48
1  
@maniat1k I've updated the question with the full output. –  George Korac May 2 '12 at 15:30
1  
Seems, you are using pretty old (and OSE) version. Isn't newer version an option? –  wk. May 2 '12 at 19:24
1  
For 10.04 (and for non-OSE version anyway) you need to use special depositories. Look here virtualbox.org/wiki/Linux_Downloads –  wk. May 2 '12 at 19:30
1  
@wk. Mhm, downloaded from there, installed, works now. The idea of this being the problem never crossed my mind. Since it worked on lower versions my first idea was that they might have removed it. Nice catch. Thanks a lot, George –  George Korac May 2 '12 at 19:39
show 3 more comments

closed as too localized by hexafraction, Tom Brossman, Jorge Castro, Ringtail, Mitch Oct 2 '12 at 9:35

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

VBoxManage modifyhd <filename> --resize <megabytes>

Is the same as allways... you may have to fix your command...

it's seems very akwar to type Windows 7 64bit.vdi it's more like Windows\ 7\ 64bit.vdi. In the other hand is a good option to go direclty to .VirtualBox/HardDisks/ and do the comand... That's how you avoid typos and so... and use tab to autocomplete the name of your vdi

if I do as follows

VBoxManage modifyhd Windows 7 64bit.vdi --resize 15360
Oracle VM VirtualBox Command Line Management Interface Version 4.1.8_OSE
(C) 2005-2012 Oracle Corporation
All rights reserved.

Usage:

VBoxManage createhd         --filename <filename>
                            --size <megabytes>|--sizebyte <bytes>
                            [--format VDI|VMDK|VHD] (default: VDI)
                            [--variant Standard,Fixed,Split2G,Stream,ESX]


Syntax error: Invalid parameter '7'

take a look.... VBoxManage do not have a parameter 7... so please check again you have a typo...

all I say is to do this... VBoxManage modifyhd Windows\ 7\ 64bit.vdi --resize 15360 on .VirtualBox/HardDisks/. good luck.

share|improve this answer
    
I know that I can't use spaces like that in paths and file names, I never said I tried executing something like that. By the way I tried that too before (switching to the disks directory and executing there directly (with \'s). Didn't make a difference because it doesn't recognize the --resize option which is what makes this really confusing for me. I've used this before without a problem and now that I've installed VirtualBox (from the Software Center) again (and even a higher version than before) it's not working, which is why I've checked the manual to see if they removed it. –  George Korac May 2 '12 at 17:42
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.