Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've Googled this to death but can't find any useful answers.

I have a Panny LCD TV which Ubuntu/Unity/Compiz has detected as a Laptop display and I'm thinking that's part of the problem.

Everything was working perfectly under 10.04 LTS. I should have been patient and waited a couple of months to upgrade.

Any help at all will be greatly appreciated.

share|improve this question
add comment

3 Answers 3

I also noticed the overscan adjustment setting was gone after upgrading to the new 304.43 driver (it was available in 295.40). While you want to have none of your image cropped it is likely your TV that is cropping (and scaling) the image and your nvidia overscan compensation is scaling it again -- producing a poor quality image. If you are sending a digital signal to your TV (eg one over HDMI, DVI-D, etc) and it is a standard resolution supported by your TV (eg 1080/60p, press 'info' on your TV) then there is no reason for the TV to crop or scale the image. But for some reason many of the TV manufacturers crop 1-2% off of the margins of the digital image (this was good for analog as the image perimeter had a lot of noise).

A better solution is to go into the 'Picture' settings in your TV menu and find the setting to not crop the image. This setting may be called 'dot by dot', '1:1 mapping', 'just scan', etc. With my LG TV it is called 'just scan' and it is one of the 'aspect ratio' settings. Now that my TV isn't cropping the picture the image looks perfect. I don't need to make any changes (like to the overscan compensation) to the Nvidia driver setup and this method will give you a perfect (unscaled) picture.

Once you TV is not cropping the image if you still have a cropped image then you are not sending the right resolution image to the TV. This would involve changing the output resolution to what the TV supports (eg 1920 x 1080, 1280 x 720, etc) in nvidia-settings. If this doesn't work then you would have to create your own Xorg.conf file with a custom ModeLine supported by your TV (not easy; google it).

share|improve this answer
    
Unfortunately the cheap Panasonics do not have a "just scan" etc. option so the only way I know of to eliminate the overscan is as I described above. –  user59574 Oct 3 '12 at 13:02
add comment
up vote 1 down vote accepted

I finally managed to eliminate overscan on my Panny 32" 720P LCD TV using a combination of "ViewPortIn" and "ViewPortOut" with the beta 302.07 driver.

I played with nvidia-settings commands until I finaly got something that worked:

nvidia-settings --assign CurrentMetaMode="DFP-0: 1920x1080 { ViewPortIn=1920x1080, ViewPortOut=1820x1020+50+30 }"

With that, I added the following line to the "Monitor" section of xorg.conf to make the settings "stick:" Option "MetaModes" "DFP-0: 1920x1080 { ViewPortIn=1920x1080, ViewPortOut=1820x1020+50+30 }"

share|improve this answer
    
How would I go about setting up two DFP with that command? I want my main monitor and a secondary HDMI monitor; they can be accessed via the names DFP-0 and DFP-1 –  Wolter Hellmund May 1 at 19:27
add comment

You might want to try this:

nvidia-settings --assign="OverScanCompensation=100"

Valid values are 0-200 i i got it right.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.