Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to 12.04 and now I can't log in because Ubuntu only allows Russian keyboard layout at login, but my password has Latin letters in it. Guest session works, and allows other languages, but I can't log in on my main account. What to do?

On Ubuntu 11.10 I used to have Swedish as default language and Russian as secondary. The first login on 12.04 worked fine, but not any more.

share|improve this question
    
Don't you have keyboard switcher on top bar of the login screen? –  wk. May 2 '12 at 13:14
    
Yes, but the thing is that I can choose only Russian. No other options are available. –  user59575 May 2 '12 at 13:39
    
If you try log on from text console (Ctrl+Alt+F1), is there also just Russian keybord active? –  wk. May 2 '12 at 14:42
    
I have same problem. You can login to Guest session, add e.g. English layout, go to User Profiles under settings, unlock it with your password and change (hopefully temporarily) your password to numbers. Not solution, but allows you to login to your own account. –  user61055 May 6 '12 at 17:11

1 Answer 1

After upgrade to 12.04 I had the exact same issue. Prior to upgrade, Greek (Polytonic) and Finnish keyboard layouts were available. After upgrade, LightDM only showed Greek (Polytonic), which prevented logging in.

I worked around this by changing the password from the virtual terminal (Ctrl-Alt-F1) by logging in and using passwd to change my password to numeric one as suggested by ggis. Then, when logged in to Unity, I reset keyboard layouts to default, re-added Greek and Finnish layouts and ordered them properly. After a few tries, I got Finnish to show up in LightDM.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.