Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 12.04 LTS Precise a few days ago. I tried installing LAMP Server as I've been done in last four Ubuntu versions, simply by using these commands:

sudo apt-get install lamp-server^
sudo apt-get install phpmyadmin

First command seems to install all needed packages for LAMP to work. It installs and configures Apache Server, PHP Modules and MySQL server, all in one. Second one installs phpMyAdmin, which I'll need for MySQL database management.

But when I open: http://localhost on my browser, nothing happens. The default page that says "It Works!" isn't shown. I tried restarting Apache a lot of times with this command:

sudo service apache2 restart

But no luck. Anyone got anything similar?

share|improve this question
    
Is there the index.html file inside /var/www? –  harisibrahimkv May 2 '12 at 12:12
    
Can you show your config file? –  Tux Dictumst May 2 '12 at 12:17
    
Paste the output of sudo service apache2 restart. –  Michael Tanner May 2 '12 at 12:17
    
Check /var/log/apache2/error.log for messages. –  Lekensteyn May 2 '12 at 14:14
    
@harisibrahimkv Yes there is. Here's its contents: <html><body><h1>It works!</h1> <p>This is the default web page for this server.</p> <p>The web server software is running but no content has been added, yet.</p> </body></html> –  Leonardo Montenegro May 2 '12 at 14:21
show 2 more comments

1 Answer

Solved my problem. My pc is under a network w/ proxy authentication, and my configs were blocking access through http://localhost. It's working fine if I access through http://[my_IP_address], so all I did was configure my pc network settings properly with the help of our network admin.

Thanks anyway :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.