Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do you do an offline installation of wx 2.8.12 for python2.7 on Ubuntu with python 2.6 as default Python? Tried searching on google but can't found anything specific. I'm a noob with Linux.

Thanks is advance

share|improve this question
    
Perhaps you can add to your question why you are using an unsupported version of Ubuntu - it may help with those who could answer your question. –  fossfreedom May 2 '12 at 12:07
    
I'm working on an IDE program for a programming language. The problem is currently that programming language runs only on several distro of Linux and of certain version too. Ubuntu 9.10 happen to be one. –  Tendou Kishi May 3 '12 at 10:52
add comment

1 Answer

Just download the .tar.gz package of wxPython for python 2.6 here. Just follow the documentation here.

After it finishes its download, I am assuming it is downloaded into /downloads folder. Then just extract the files to a folder. let's assume it wxpython. Now I just recommend you to use easy_install to install modules for multiple version of python. Just download it to insatll it offline like this:

cd Downloads
cd setuptools
sudo python setup.py install

This will install the setuptools for python which will installl easy_install for you automatically. Now download virtual environment package tarball here. You can install it in similar fashion you installed the above easy_package. Remember, all thing is going offline except for the packages to be downloaded externally.
Now you have a virtual environment package, you can create virtual environment for each project you follow like this:

virtualenv -p python2.6 --no-site-packages ~/env/NEW_PYTHON_PROJECT

read full documentation here.

ELSE you can easily install modules for each python version specifically like:

sudo python2.5 easy_install package_name
share|improve this answer
    
Sorry, but your answer is using Python 2.6. My question is installing wx for Python 2.7 where there are 2 Pythons, one is 2.7 and other (default) is 2.6. –  Tendou Kishi May 3 '12 at 10:54
    
Just do it for python2.7 for the same way i have done it for python 2.6. I have tried that and i also succeeded for creating two python environments. Actually, I now work in python2.7 and use python 2.6 for cryptographic and other module –  ashutosh May 3 '12 at 11:16
    
If that code worked for you(i mean for python2.7), just make it the answer. –  ashutosh May 3 '12 at 11:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.